warum werden die ausgelesenen forminhalte nicht i

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

warum werden die ausgelesenen forminhalte nicht i

Postby sandra » 30. May 2003 14:05

Hallo,
ich habe ein Programm, dass eingetragenen Formelemente ausliest und in eine Datenbank schreibt.
Am Pc läuft alles wunderbar. Nicht unter Unix!!
Die Forminhalte werden mithilfe von alert in die adressleiste des Browsers ausgegeben, doch dann nicht in die db geschrieben. Auch keine Fehlermeldungen (Verbindung zur DB besteht aucht)

weiss jemand Rt?? (das "Ausführen" php-Dateien habe ich bereits deaktiviert) Liegt es vielleicht irgendwie an Sicherheitsrechten, die unter Unix ja so umfangreich und relevant sind?
ich habe in der DB keine mysql.,.,.passwords gesetzt und in db_connect.php sieht so aus:
$mysqluser = "";
$mysqlpasswd = "";
$mysqlhost = "localhost";
$db = "radiomondoDB";

vielen Dank Sandra

ein Ausschnitt des insert scripts:
<?php........
...... if ($text != "")
{
$anfrage2 = "INSERT INTO messages(text,style,color,fadein,fadeout,position,static) VALUES (\"$text\",\"$styl\"+1,\"$col\",\"$fadei\"+1,\"$fadeo\"+1,\"$posit\"+1,\"$stati\")";
mysql_query($anfrage2, $connID);
}
sandra
 

Postby AlexPausB » 30. May 2003 14:21

Sandy wrote:ich habe in der DB keine mysql.,.,.passwords gesetzt und in db_connect.php sieht so aus:
$mysqluser = "";
$mysqlpasswd = "";
$mysqlhost = "localhost";
$db = "radiomondoDB";


Also standardmässig is der User "root" - setz das dochmal in bei $mysqluser ein und probiers noch a ma...

Andererseits hast Du ja geschrieben, dass die Verbindung zur DB hergestellt ist... hm...
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Datenbankverbindung OK -vielleicht noch ne Lösung parat?

Postby Sandra » 01. June 2003 15:21

Ja keine Fehlermeldung dass Datenbankverbindung nicht aufgebaut werden konnte.
An was könnte das Problem noch liegen??

Grüße Sandra
Sandra
 

Postby Kristian Marcroft » 01. June 2003 15:39

Hi,

kommen die Variablen aus nem Formular?
Globals auf yes?
Es kommt keine Fehlermeldung, da du keine Definiert hast.
... OR DIE "Es konnte keine Verbindung zu mySQL aufgebaut werden";

Wäre mein Tipp :)
Is aber schon etwas länger her das ich mich mit mySQL beschäftigt habe :)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

es funktioniert mit"$mysql user=root"

Postby sandra » 02. June 2003 12:34

vielen dank,
musste nur root eintragen und schon läuft's. er trägt zwar nicht alles in die db, aber zumindest einen teil

danke schön
sandra
sandra
 


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests