virutalhosts

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

virutalhosts

Postby victorvox » 25. June 2005 18:57

Hallo, folgende Frage...

ich habe einen server im internet hängen, habe eine öffentliche ip adressen und habe aber 3 unterschiedliche domains! jede domain liegt in ihrem eigenen ordner unter /opt/lampp/htdocs / 1 oder /2 oder 3

jetzt möchte ich das wenn jemand auf www.xamppistsuper.de geht mein webserver versteht das er auf ordner 2 gehen soll usw.
habe es schon versucht mit virtualhost jedoch ohne erfolg!
was mache ich evt falsch?

vielen Dank für eine Antwort
Gruß
Victor :oops:
yew
victorvox
 
Posts: 4
Joined: 25. June 2005 18:53

Postby Wiedmann » 25. June 2005 19:18

Ich rate jetzt mal, dass der Rechner gar nicht an ist?

Ansonsten solltest du uns schon sagen,
- was genau du bisherher gamacht hast
- pass passiert und/oder nicht passiert
- evtl. Fehlermeldungen, Einträge im Log.

Wie VHosts prinzipiell eingerichtet werden siehst du z.B. hier:
http://community.apachefriends.org/f/viewtopi ... host#34538
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

hilfe

Postby victorvox » 26. June 2005 00:27

servus und hallo,
leider bin ich nicht weitergekommen :twisted:

ich habe jetzt alles so gemacht wie es erklärt wird auch auf deinem link! danke jedoch kein erfolg.

meine problemmst.

1 root server , immer online ip internet 19.1.1.1
2 domains beide gehen auf die gleiche ip!

jetzt möchte ich domain 1 auf /opt/lampp/htdocs1
und domain 2 auf /opt/lampp/htdocs2

ich bekomme es nicht hin!! jedesmal wenn ich es versuche wie laut anleitung
danach den server neustarte ist auf port 80 tote hose, baue ich keinen vh ein geht er direkt auf /opt/lampp/htdocs ( beide domains )

bitte helft mir!
danke
victor
yew
victorvox
 
Posts: 4
Joined: 25. June 2005 18:53

Postby Wiedmann » 26. June 2005 00:46

ich habe jetzt alles so gemacht wie es erklärt wird auch auf deinem link! danke jedoch kein erfolg.

Dann poste doch mal deine Konfiguration von den VHosts.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

httpd

Postby victorvox » 26. June 2005 09:53

Code: Select all
<VirtualHost *:80>
    ServerName 217.11.61.177:80
    DocumentRoot /opt/lampp/htdocs/domain1
    <Directory /opt/lampp/htdocs/domain1>
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>

<VirtualHost *:80>
    ServerName 217.11.61.177:80
    DocumentRoot /opt/lampp/htdocs/domain2
    <Directory /opt/lampp/htdocs/domain2>
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>
yew
victorvox
 
Posts: 4
Joined: 25. June 2005 18:53

Postby deepsurfer » 26. June 2005 11:28

ServerName 217.11.61.177:80


In beiden statt der IP den Domain namen eintragen, weil der Domainname beim auflösen auf deine IP geht aber vom Apache dann wieder aufgenommen wird und dann in richtige verzeichnis leitet.

So wie es jetzt ist wird nur die IP von dir angenommen und somit immer vom ersten VHOST beantwortet.

<VirtualHost *:80>
ServerName damain1
DocumentRoot /opt/lampp/htdocs/domain1
<Directory /opt/lampp/htdocs/domain1>
Order Allow,Deny
Allow from all
#Options All
#AllowOverride All
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName domain2
DocumentRoot /opt/lampp/htdocs/domain2
<Directory /opt/lampp/htdocs/domain2>
Order Allow,Deny
Allow from all
#Options All
#AllowOverride All
</Directory>
</VirtualHost>
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

geht immer noch nicht

Postby victorvox » 26. June 2005 16:37

hallo, danke für eure antworten bisher, leider immer noch kein erfolg,
jetzt habe ich alles so gemacht wie beschrieben im letzten post und jetzt kommt folgender fehler:

[Sun Jun 26 17:16:00 2005] [error] VirtualHost www.domain2.de:0 --
mixing * ports and non-* ports with a NameVirtualHost address is not
supported, proceeding with undefined results




:oops: :oops:
yew
victorvox
 
Posts: 4
Joined: 25. June 2005 18:53

Du mußt Dich entscheiden

Postby bitkiller » 01. July 2005 19:10

Entweder machst Du namensbasierte vituelle Hosts oder nicht

am einfachsten ist du nimmst die NameVirtualHosts.

Dazu muß Du in der httpd.conf folgendes eintragen:

NameVirtualHosts 192.168.0.5:80
# Verzeichnisse jeweils ohne / am Ende !!!
<VirtualHost 192.168.0.5:80>
ServerName server1.domain.de
DocumentRoot /PFADANGABEN/VERZEICHNIS
</Virtualhost>

<VirtualHost 192.168.0.5:80>
ServerName server2.domain.de
DocumentRoot /ANDEREPFADANGABEN/VERZEICHNIS
</Virtualhost>
bitkiller
 
Posts: 1
Joined: 01. July 2005 18:54


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests