Kann keinen mysqldump einspielen

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Kann keinen mysqldump einspielen

Postby Frameboy » 23. June 2005 15:41

Hallo liebe Community

Wenn ich ein mit Putty von meinem echten Forum erstelltes Backup in mein mit af realisiertes Testboard mit Putty wieder einspielen will, bekomme ich die Fehlermeldung
Code: Select all
Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
, obwohl ich im Webmin die Konfiguration des mysql-Servers auf af angepasst habe.
Wo habe ich noch vergessen, den Pfad auf
Code: Select all
/opt/lampp/var/mysql/mysql.sock
zu ändern?

Gruß Frameboy
Hallo?
Hallo??
Was passiert denn da?
Frameboy
 
Posts: 16
Joined: 17. August 2004 15:19
Location: Worms

Postby Kristian Marcroft » 23. June 2005 16:34

Hi,

wieso spielst du mit Webmin herum?
Spiel das Backup via console wieder ein.

/opt/lampp/bin/mysql sollte dir dabei helfen.
Falls du weitere hilfestellung brauchst in der FAQ http://faq.kwm-web.info stehen ein paar Infos dazu wie?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Frameboy » 23. June 2005 16:58

Kristian Marcroft wrote:Spiel das Backup via console wieder ein.

Ich habe es ja mit Putty versucht und bekomme die genannte Fehlermeldung!

Mein Webmin funktioniert ja anstandslos!

Es muß halt nur irgendwo sonst noch die falsche Pfadangabe sein. Ich möchte gerne wissen wo!
Hallo?
Hallo??
Was passiert denn da?
Frameboy
 
Posts: 16
Joined: 17. August 2004 15:19
Location: Worms

Can't connect ot local MySQL Server though socket...

Postby Clausen » 26. June 2005 14:02

Hallo,

hab' genau das gleiche Problem. Ich habe die neueste Slackware-Distribution auf einer virtuellen VMWare Maschine installiert und dann Xampp drüber. Alles funktioniert gut, der Start von XAMPP ohne Probleme, DB läuft auch, aber als ich versuchte, mit 'mysql ... <dump.msql' ein Backup zurückzuspielen, kriegte ich folgende Fehlermeldung:

Can't connect to local MySQL Server through socket '/var/run/mysql/mysql.sock'

Habe schon rausgefunden, dass sich die .sock Datei bei Xampp in /opt/lampp/var/mysql/ befindet, ich habe aber keine Ahnung, wie ich Linux diese Änderung mitteilen soll.

(kann über TCP/IP von einem anderen Rechner auf Mysqld zugreifen, versucht mit 'mysqladmin --host=linux-server --port=xxxx version', also mysqld funktioniert)

Gruss, Ulf
Clausen
 
Posts: 6
Joined: 26. June 2005 13:53

Postby Wiedmann » 26. June 2005 14:10

aber als ich versuchte, mit 'mysql ... <dump.msql' ein Backup zurückzuspielen, kriegte ich folgende Fehlermeldung:

Das würde so aber nur tun, wenn du auch von deinem System einen MySQL installiert hast.

So müsste es doch gehen?
/opt/lampp/bin/mysql ... <dump.msql
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Clausen » 26. June 2005 23:09

Nein, leider nicht - gleiches Problem, er sucht den Socket immer noch unter usr/var... und nicht unter /opt/lampp.
Ich glaube, als Slackware installiert wurde habe ich aus versehen auch MySQL mitinstalliert. Wenn ich doch nur wüsste wo diese Einstellung auf das andere MySQL gespeichert ist? Ich habe auf dem System nur eine my.cnf gefunden, die auch die richtigen Pfade enthält. Irgendwelche Tipps?
Clausen
 
Posts: 6
Joined: 26. June 2005 13:53

Postby Wiedmann » 27. June 2005 00:04

Du hast das Kommando wirklich genauso eingegeben?

Ansonsten (und) muss es noch wo eine my.cnf geben.

Was gibt denn dieses Kommando aus?
Code: Select all
find / -name "*my.cnf" -print
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Clausen » 28. June 2005 12:03

Merkwuerdig, ich habe das nochmal genauso eingegeben, aber immer noch der gleiche Fehler. find hat keine andere my.conf gefunden. Hab gestern dann die Nase voll gehabt und Slackware neu installiert und darauf geachtet dass ich das integrierte MySQL nicht mitinstalliere - jetzt geht alles perfekt und meine alte Datenbank liess sich ohne Probleme einspielen.

Manchmal frage ich mich dann aber doch wie kompliziert Linux eigentlich ist:
Hab sonst alles genau wie beim ersten Mal gemacht, aber jetzt hatte ProFTP ploetzlich Probleme mit ReverseDNS und ich musste dass auf off setzen in der config. Ausserdem geht jetzt die Flash-Demo auf der Begruessungsseite nicht mehr - Rechtsklick auf das Flash-Window zeigt alle moeglichen Flash-Optionen, ist also installiert, aber keine rotierenden Zeilen mehr...

Naja, werde ich wohl irgenwann auch noch ergruenden... Danke fuer die Hilfe anyway...
Clausen
 
Posts: 6
Joined: 26. June 2005 13:53

Postby deepsurfer » 28. June 2005 14:06

find hat keine andere my.conf gefunden


nicht my.conf, sondern my.cnf !!
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Clausen » 28. June 2005 18:14

Sorry, I hab' natürlich .cnf aufprobiert, war nur ein Schreibfehler im posting.
Clausen
 
Posts: 6
Joined: 26. June 2005 13:53


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests