xampp-linux-1[1].4.14-beta1.tar.gz

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

xampp-linux-1[1].4.14-beta1.tar.gz

Postby tigermann1 » 13. June 2005 09:35

Das neue Paket xampp-linux-1[1].4.14-beta1.tar.gz wurde zum Testen ins Netz gestellt, aber mit den Befehl tar xvfz linux-1[1].4.14-beta1.tar.gz -C /opt lässt sich das Paket nicht installieren???
tigermann1
 
Posts: 27
Joined: 30. April 2005 15:10

Re: xampp-linux-1[1].4.14-beta1.tar.gz

Postby DJ DHG » 13. June 2005 09:45

Moin Moin
tigermann1 wrote:Das neue Paket xampp-linux-1[1].4.14-beta1.tar.gz wurde zum Testen ins Netz gestellt, aber mit den Befehl tar xvfz linux-1[1].4.14-beta1.tar.gz -C /opt lässt sich das Paket nicht installieren???


Und wie äußert sich das?

Ist die MD5 Checksumme OK?
ce9c1509e28196d4c8690e245cf29d3e

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tigermann1 » 13. June 2005 10:02

Wie fragst die MD5 Checksumme ab? Sorry das ich so blöd frage, bin noch kein Linux-Experte, muss noch einiges Lernen.
tigermann1
 
Posts: 27
Joined: 30. April 2005 15:10

Postby DJ DHG » 13. June 2005 10:07

Das geht mit md5sum <filename>

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tigermann1 » 13. June 2005 10:27

Ist der im Xampp-Paket INTEGRIERT, oder kann der EXTRA runtergeladen werden, oder ist der MD5sum bereits unter Linux installiert und kann in der Konsole aufgerufen werden???
tigermann1
 
Posts: 27
Joined: 30. April 2005 15:10

Postby DJ DHG » 13. June 2005 10:32

tigermann1 wrote:Ist der im Xampp-Paket INTEGRIERT, oder kann der EXTRA runtergeladen werden, oder ist der MD5sum bereits unter Linux installiert und kann in der Konsole aufgerufen werden???


Nein, es ist nicht in Xampp enthalten.
Es muss in der Konsole auf gerufen werden.
Ob es bei dir schon installiert ist ,kann ich dir nicht sagen, bin ja kein Hellseher :wink:

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tigermann1 » 13. June 2005 10:39

Alles klar :lol: , mit welchen Befehl rufe ich das jetzt in der Konsole ab, wenn das Test-Paket im Root-Verzeichnis liegt?
tigermann1
 
Posts: 27
Joined: 30. April 2005 15:10

Postby DJ DHG » 13. June 2005 10:46

Hab ich doch bereits oben schon geschrieben!?
Must nur den Pfad mit angeben.

mfg DJ DHG

btw:
http://www.selflinux.org/selflinux/
http://www.linuxfibel.de/
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tigermann1 » 13. June 2005 11:37

Jaaa es geht, der Pfad lautet also md5sum xampp-linux-1[1].4.14-beta1.tar.gz
und als Ergebnis bekamm ich ce9c1509e28196d4c8690e245cf29d3e
Bedanke mich recht schön, aber wenn ich den Befehl tar xvfz linux-1[1].4.14-beta1.tar.gz -C /opt eingebe, kommt tar: linux-1[1].4.14-beta1.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
Kann es sein, das das Xampp-Paket 1.4.13 installiert sein muss, damit sich die beta version installieren lässt???
tigermann1
 
Posts: 27
Joined: 30. April 2005 15:10

Postby DJ DHG » 13. June 2005 11:44

MD5 stimmt. Das ist schonmal gut.
Ich habe mich schon vorhin beim Thread-Title gewundert,
was du für einen komischen Dateinamen da hast.
xvfz linux-1[1].4.14-beta1.tar.gz

Sollte eigentlich so sein.
xampp-linux-1.4.14-beta1.tar.gz

Umbennen und nochmal versuchen.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tigermann1 » 13. June 2005 13:12

Ja jetzt hat es geklappt. Nur eins versteh ich nicht, wenn ich http://localhost/cgi-bin/printenv.pl aufrufe, kommt Not Found
The requested URL /cgi-bin/printenv.pl was not found on this server, obwohl der Testaufruf von http://localhost positiv ist.
tigermann1
 
Posts: 27
Joined: 30. April 2005 15:10

Postby DJ DHG » 13. June 2005 13:54

tigermann1 wrote:Ja jetzt hat es geklappt. Nur eins versteh ich nicht, wenn ich http://localhost/cgi-bin/printenv.pl aufrufe, kommt Not Found
The requested URL /cgi-bin/printenv.pl was not found on this server, obwohl der Testaufruf von http://localhost positiv ist.


Das liegt daran, dass die "printenv" (ohne .pl) heist.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby tigermann1 » 13. June 2005 16:11

Wenn ich http://localhost/cgi-bin/printenv ohne.pl aufrufe, gibt er mir nur die Textausgabe aus.
tigermann1
 
Posts: 27
Joined: 30. April 2005 15:10

Postby deepsurfer » 13. June 2005 16:59

Wenn ich http://localhost/cgi-bin/printenv ohne.pl aufrufe, gibt er mir nur die Textausgabe aus.


1) Meinst du das hier ????, dann ist es richtig = ergebnis von printenv

Code: Select all
DOCUMENT_ROOT="/opt/lampp/htdocs"
GATEWAY_INTERFACE="CGI/1.1"
HTTP_ACCEPT="text/xml,application/xml,application/xhtml+xml,text/html;
q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5"

HTTP_ACCEPT_CHARSET="ISO-8859-1,utf-8;q=0.7,*;q=0.7"
HTTP_ACCEPT_ENCODING="gzip,deflate"
HTTP_ACCEPT_LANGUAGE="de,de-de;q=0.8,en;q=0.5,en-us;q=0.3"
HTTP_CONNECTION="keep-alive"
HTTP_COOKIE="user_search_field=first_name"
HTTP_HOST="192.168.0.200"
HTTP_KEEP_ALIVE="300"
HTTP_USER_AGENT="Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4"
PATH="/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:
/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/opt/kde3/bin:
/usr/lib/jvm/jre/bin"

QUERY_STRING=""
REMOTE_ADDR="192.168.0.158"
REMOTE_PORT="2182"
REQUEST_METHOD="GET"
REQUEST_URI="/cgi-bin/printenv"
SCRIPT_FILENAME="/opt/lampp/cgi-bin/printenv"
SCRIPT_NAME="/cgi-bin/printenv"
SERVER_ADDR="192.168.0.200"
SERVER_ADMIN="you@your.address"
SERVER_NAME="192.168.0.200"
SERVER_PORT="80"
SERVER_PROTOCOL="HTTP/1.1"
SERVER_SIGNATURE="<address>Apache/2.0.54 (Unix) mod_ssl/2.0.54 OpenSSL/0.9.7g PHP/5.0.4 DAV/2 mod_perl/1.999.21 Perl/v5.8.6 Server at 192.168.0.200 Port 80</address>\n"
SERVER_SOFTWARE="Apache/2.0.54 (Unix) mod_ssl/2.0.54 OpenSSL/0.9.7g PHP/5.0.4 DAV/2 mod_perl/1.999.21 Perl/v5.8.6"
UNIQUE_ID="lI4L@sCoIIkAACCoT5wAAAAG"


2) oder meinst du das hier ??, dann liegt ein fehler vor

Code: Select all
#!/opt/lampp/bin/perl
##
##  printenv -- demo CGI program which just prints its environment
##

print "Content-type: text/plain\n\n";
foreach $var (sort(keys(%ENV))) {
    $val = $ENV{$var};
    $val =~ s|\n|\\n|g;
    $val =~ s|"|\\"|g;
    print "${var}=\"${val}\"\n";
}


Wenn Punkt 2, hast du etwas an der HTTPD.CONF geändert ??
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby tigermann1 » 13. June 2005 18:14

Die Datei printenv ist unter Linux als TEXTAUSGABE gedacht. Unter Windows wird sie als html ausgeben. Das war etwas verwirrend, da ich xampp am Anfang meiner ERSTEN Studien unter Windows installierte. Möchte grade den Online-Kurs von http://www.stephan-muller.com machen, bring aber das Script "Hallo World' nicht zum Laufen? Liegt es daran, das mit Xampp der Zusatz -wT nicht ausgeführt werden kann?

#!/usr/bin/perl -wT

use strict;

print <<"EOF";
Content-Type:text/html


<html>
<head><title>Hello World</title></head>
<body>
<center>Hello World!</center>
</body>
</html>
EOF
tigermann1
 
Posts: 27
Joined: 30. April 2005 15:10

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests