Fehler bei Mono installation

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Fehler bei Mono installation

Postby Du-weisst-schon-wer » 10. June 2005 21:51

Habe euer XAMPP 1.4.12 auf Fedora Core 2 laufen.
Hab jetzt mit dem Installer mono installiert und
in der httpd.conf
folgendes hinzugefügt:

Code: Select all
LoadModule mono_module /opt/mono-1.1.7-1/lib/httpd/modules/mod_mono.so
Alias /test "/opt/mono-1.1.7-1/share/doc/xsp/test"
AddMonoApplications default "/test:/opt/mono-1.1.7-1/share/doc/xsp/test"
<Location /test>
   SetHandler mono
</Location>



Beim start kommt aber:
Code: Select all
[root@dhcppc5 root]# /opt/lampp/lampp restart
Stoppe XAMPP fuer Linux 1.4.12...
XAMPP: Stoppe Apache mit SSL...

httpd: module "mod_mono.c" is not compatible with this version of Apache (found 20020628, need 20020903).
Please contact the vendor for the correct version.

XAMPP: Stoppe MySQL...
XAMPP: Stoppe ProFTPD...
XAMPP beendet.
Starte XAMPP fuer Linux 1.4.12...
XAMPP: XAMPP-Apache laeuft bereits.
XAMPP: Starte MySQL...
XAMPP: Starte ProFTPD...
XAMPP fuer Linux gestartet.
[root@dhcppc5 root]#

Damit kann ich sogut wie nichts anfangen. Wer kann mir helfen?
Du-weisst-schon-wer
 
Posts: 10
Joined: 29. June 2004 12:00

Postby deepsurfer » 11. June 2005 11:15

Code: Select all
httpd: module "mod_mono.c" is not compatible with this version of Apache (found 20020628, need 20020903).
Please contact the vendor for the correct version.


Diese Aussage sollte alles besagen was du brauchst, suche mal im Web nach dem Autor der "mod_mono.c" dort dürfte dann ein download sein mir der benötigten Versionsnummer 20020903.

Hab mich mit Modulen aktualisierung so noch nicht befasst, sichelrich gibt es noch eine bequemere Lösung (vielleicht kommt Wiedmann hier noch vorbei und hat aus dem stehgreif ein Lösung :oops: )

Vielleicht ist auch auf der "mono" Autoren Seite ein Hinweis vorhanden ?!?

EDIT:
Schau mal nach ob noch eine mod_mono.so bei dir vorhanden ist und lad dieses Modul in der httpd.con ein.
In der Installanleitung des mono wird auf dieses modul verwiesen.
Quelle: http://www.mono-project.com/Mod_mono
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests