Problem unter debian mit mysql-Client

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Problem unter debian mit mysql-Client

Postby Deejoy » 10. June 2005 20:08

Hi,
habe gerade mal Lampp Version 1.4.13 unter Debian Sarge installiert bekomme jedoch bei div. Anwendungen (Postfix, Webmin) beim Mysql Zugriff folgende fehlermeldung
Code: Select all
DBI connect failed : Client does not support authentication protocol requested by server; consider upgrading MySQL client


Den mysql-client-4.1 habe ich jedoch bereits installiert.
Deejoy
 
Posts: 26
Joined: 15. July 2004 21:29

Postby Wiedmann » 10. June 2005 20:18

Den mysql-client-4.1 habe ich jedoch bereits installiert.

Was aber nicht heisst, das eine Anwendung diesen benutzen muss.

DBI connect failed

Das hört sich nach Perl an. "DBD::mysql" dürfte nicht aktuell sein...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 10. June 2005 20:26

Andersherum gegengefragt !

1) Beim starten des XAMPP kam keine Fehlermeldung ?

2) Hast du beim aufruf http://localhost (oder ip des Debian-PC falls du von LAN aus zugreifen willst) das Willkommenscreen von XAMPP ?

3) Hast du den Webmin vom XAMPP-Addon installiert oder einen eigenen ?

4) Beim Installieren des SARGE hast du da angegeben das er den MySQL installieren soll ?


Ich vermute das Du einfach dem SARGE alles Installieren liessest und zusätzlich den XAMPP hinzugefügt hast, ohne den Debian-Apche und Debian-MySQL abzuschalten.
Und wenn du einen eigenen Webmin Installiert hast, so hat dieser keine Kenntnis von der Existenz des XAMPP (da muss man einiges umstricken)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Deejoy » 10. June 2005 20:47

deepsurfer wrote:Andersherum gegengefragt !

1) Beim starten des XAMPP kam keine Fehlermeldung ?

2) Hast du beim aufruf http://localhost (oder ip des Debian-PC falls du von LAN aus zugreifen willst) das Willkommenscreen von XAMPP ?

3) Hast du den Webmin vom XAMPP-Addon installiert oder einen eigenen ?

4) Beim Installieren des SARGE hast du da angegeben das er den MySQL installieren soll ?


Ich vermute das Du einfach dem SARGE alles Installieren liessest und zusätzlich den XAMPP hinzugefügt hast, ohne den Debian-Apche und Debian-MySQL abzuschalten.
Und wenn du einen eigenen Webmin Installiert hast, so hat dieser keine Kenntnis von der Existenz des XAMPP (da muss man einiges umstricken)


zu1) nein kam keine MYSQL läuft soweit ja auch
zu2) ja
zu3) nein ich habe das Debian und mir es selbst angepasst hat bisher ja auch wunderbar mit XAMMP funktioniert (zuletzt 1.4.9) bis heute.
um es gleich vorweg zu nehmen ich habe das alte XAMPP komplett gelöscht und 1.4.13 neu installiert.
zu4) Nein habe ich nicht. Von debian ist weder Apache noch der Mysql Server installiert lediglich der mysqlclient-4.1 und mysql-common-4.1 ist installiert.

Wie gesagt mit der XAMPP 1.4.9 lief noch alles einwandfrei
Deejoy
 
Posts: 26
Joined: 15. July 2004 21:29

Postby Deejoy » 10. June 2005 21:16

Das hört sich nach Perl an. "DBD::mysql" dürfte nicht aktuell sein...


Perl hört sich gut an scheint nämlich auf den falschen Socket zu greifen
Deejoy
 
Posts: 26
Joined: 15. July 2004 21:29


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests