php neu kompilieren

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

php neu kompilieren

Postby h-net » 13. May 2005 22:01

hi...

das is eigentlich eine frage an die andmins von apachefriends(xampp)...

also... ich habe ein gaaanz großes problem.... wenn ihr mir helfen würdet, wüsst ich garnet wie ich auch danken sollte....

also:

ich habe xampp runterleladen... geht ja normalerweise einwandfrei... aber ich bi ndarauf angeweisen das ich nicht den enthaltenen mysql-server benutze, sondern ich MUSS einen anderen benutzen.... der läuft auch schon...
nur kann ich jetzt natürlich mit php(das was bei xampp dabei ist) nicht auf meine mysql-datenbank zugreifen, da ja eine andere mysql.sock beim compilieren angegeben wurde...

jetzt meine bitte:
kann mir jemand sagen, wie ich nun mit dem bei xampp enthaltenen php auf meine mysql-datenbank zugreifen kann? gibts da irgend einen trick?
oder könnte mir einer der admins sagen, wie ich das anstelle php neu zu kompilieren, so das ich es in xampp einbetten kann?
ich würde ja alles selber kompilieren, aber ich weis nicht wie ich das asntellen soll, wär also echt toll wenn mir jemand sagen könnte wie ich mein problem lösen kann...

schon mal vielen dank im vorraus...
h-net
h-net
 
Posts: 19
Joined: 26. January 2004 22:34

Postby Wiedmann » 13. May 2005 22:18

nur kann ich jetzt natürlich mit php(das was bei xampp dabei ist) nicht auf meine mysql-datenbank zugreifen, da ja eine andere mysql.sock beim compilieren angegeben wurde...

aha...

a) und warum gibst du dann beim mysql_connect() nicht den Socket an den du haben willst?

oder b) http://de.php.net/manual/en/ref.mysql.php --> Table 1. MySQL Configuration Options
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby h-net » 13. May 2005 22:34

>>a) und warum gibst du dann beim mysql_connect() nicht den Socket an den du haben willst?

wo soll ich den angeben?
wenn ich z.b. php my admin aufrufe sagt er das er nicht zum mysql.sock-file connectieren kann....(#2002 - Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)) das wird doch beim compilieren von pgp mit angegeben oder?
h-net
 
Posts: 19
Joined: 26. January 2004 22:34

Postby Wiedmann » 13. May 2005 22:49

wenn ich z.b. php my admin aufrufe sagt er das er nicht zum mysql.sock-file connectieren kann....

Welchen Socket ein bestimmtes Programm beim mysql_connect benutzt, kann man oft in der jeweiligen Config-Datei festlegen. Im Falle von phpMyAdmin wäre das die "config.inc.php".

das wird doch beim compilieren von pgp mit angegeben oder?

Da wird der Default vorgegeben, falls ein Programm beim mysql_connect() den Host 'localhost' oder keinen angibt. Dieser Default lässt sich aber, wie du ja mittlerweiler bei dem Link oben nachgelesen hast, auf einen anderen Wert festlegen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby PF4 » 13. May 2005 22:51

Hi,

wie gesagt du musst nur den socket anpassen in der php.ini oder über 127.0.0.1 connecten. Steht aber alles auf der Seite die Wiedmann vorher gepostet hat!
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby h-net » 13. May 2005 22:54

nene.. ich glaub wir meinen was verschiedenes... ich verstehs auchnet so ganz warum das so ist, wei es sit, aber beim kompilieren von php wird die locale datenbank mit angegeben.... das hat nix mit mysql_connect() von php zu tun glaub ich....
das kompilier comando von xampp-php ist ja:
'./configure' '--prefix=/opt/lampp' '--with-apxs2=/opt/lampp/bin/apxs' '--with-config-file-path=/opt/lampp/etc' '--with-mysql=/opt/lampp' '--disable-debug' '--enable-bcmath' '--enable-calendar' '--enable-ctype' '--enable-dbase' '--enable-discard-path' '--enable-exif' '--enable-filepro' '--enable-force-cgi-redirect' '--enable-ftp' '--enable-gd-imgstrttf' '--enable-gd-native-ttf' '--with-ttf' '--enable-magic-quotes' '--enable-memory-limit' '--enable-safe-mode' '--enable-shmop' '--enable-sigchild' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-versioning' '--enable-wddx' '--enable-yp' '--with-ftp' '--with-gdbm=/opt/lampp' '--with-jpeg-dir=/opt/lampp' '--with-png-dir=/opt/lampp' '--with-freetype-dir=/opt/lampp' '--without-xpm' '--with-zlib=yes' '--with-zlib-dir=/opt/lampp' '--with-openssl=/opt/lampp' '--with-expat-dir=/opt/lampp' '--enable-xslt=/opt/lampp' '--with-xsl=/opt/lampp' '--with-ming=/opt/lampp' '--with-dom=/opt/lampp' '--with-ldap=/opt/lampp' '--with-ncurses=/opt/lampp' '--with-gd' '--with-imap-dir=/opt/lampp' '--with-imap-ssl' '--with-imap=/opt/lampp' '--with-gettext=/opt/lampp' '--with-mssql=/opt/lampp' '--with-interbase=shared,/opt/interbase' '--with-mysql-sock=/opt/lampp/var/mysql/mysql.sock' '--with-oci8=shared' '--with-mcrypt=/opt/lampp' '--with-mhash=/opt/lampp' '--enable-sockets' '--enable-mbstring=all' '--with-curl=/opt/lampp' '--enable-mbregex' '--enable-zend-multibyte' '--with-zip=/opt/lampp' '--enable-exif' '--with-bz2=/opt/lampp' '--with-sqlite=shared' '--with-libxml-dir=/opt/lampp' '--enable-soap' '--enable-pcntl' '--enable-dbx' '--with-mysqli=/opt/lampp/bin/mysql_config' '--with-mime-magic'

und eben diese mysql.sock verwende ich nicht mehr... sondern die von der anderen datenbank... php kann da aber nicht drauf zugeifen, weil ihm ja gesagt wurde das er auf diese datenbank: /opt/lampp/var/mysql/mysql.sock
zugreifen soll...

und ich woltle eben wiessen wie ich es anders kompiliere, oder php überlisten kann
h-net
 
Posts: 19
Joined: 26. January 2004 22:34

Postby PF4 » 13. May 2005 22:55

Wurde jetzt schon 3 mal geschrieben, lies mal die Beiträge!
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby h-net » 13. May 2005 22:59

ohh sorry.... IHR SEID GÖTTER!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

DAAAAAAAAAAAAAAAAAANNNNNNNNNNNKKKKKKKKKKEEEEEEEEEEEEE

jetz hab ich nru noch den fehler:
#1045 - Access denied for user: 'pma@localhost' (Using password: NO)

wenn ich mich in phpmyadmin anmelden will
h-net
 
Posts: 19
Joined: 26. January 2004 22:34

Postby PF4 » 13. May 2005 23:01

Hi,
da es in deiner neuen DB warscheinlich keinen pma User geben wird musst du phpmyadmin eben so configen das er _KEINEN_ kontrollnutzer benutzt.
Siehe dazu config.inc.php!
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby h-net » 13. May 2005 23:05

yeah is das geil.... VIELEN DANK... heir nochmal meine lösung für google.. falls mal jemand das geliceh probem hat:

einfach in der php.ini eintragen:
mysql.default_socket = /pfad/zu/eurer/mysqld.sock

gruß
h-net
 
Posts: 19
Joined: 26. January 2004 22:34

Postby shevegen » 18. May 2005 01:51

hehe wo is das wiki wo is das wiki ! :>
User avatar
shevegen
 
Posts: 107
Joined: 08. June 2004 04:52

Postby Kristian Marcroft » 18. May 2005 11:02

shevegen wrote:hehe wo is das wiki wo is das wiki ! :>


in Arbeit ;)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests