No /opt/lampp/bin/php

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

No /opt/lampp/bin/php

Postby tribunal89 » 16. April 2005 21:54

Die datei gibt es aber? Was soll ich machen? hab es schon 2 mal heruntergeladen und entpackt, immer der selbe Fehler.

Code: Select all
tobiasfs:/ # ./opt/lampp/lampp start
Starting XAMPP for Linux 1.4.9a...
/opt/lampp/bin/php: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory
XAMPP: Starting Apache with SSL ...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.
tobiasfs:/ #


System:
    Suse Linux 9
    P4 2.4Ghz
    200GB Festplatte
    Nvidia Geforce 3
tribunal89
 
Posts: 7
Joined: 16. April 2005 21:33

Postby deepsurfer » 17. April 2005 09:49

Die datei gibt es aber? Was soll ich machen? hab es schon 2 mal heruntergeladen und entpackt, immer der selbe Fehler.


In welchem Pfad gibt es denn die libcurl.so.3 bei dir ????
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby tribunal89 » 17. April 2005 10:45

In welchem Pfad gibt es denn die libcurl.so.3 bei dir ????


Wo finde ich den die datei? Wo sollte sie den stehen?
Ich habe Lampp unter /opt installiert.
-----------------------------------------------------------------------------------------------------
So ich hab es geschafft das lampp startet.
Code: Select all
tobiasfs:/ # ./opt/lampp/lampp start
Starting XAMPP for Linux 1.4.13...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

Wenn ich aber jetzt local host eingebe kommt:
Code: Select all
Forbidden


You don't have permission to access / on this server.


Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.0.53 (Unix) mod_ssl/2.0.53 OpenSSL/0.9.7d PHP/5.0.4 DAV/2 mod_perl/1.999.21 Perl/v5.8.6 Server at localhost Port 80
tribunal89
 
Posts: 7
Joined: 16. April 2005 21:33

Postby deepsurfer » 17. April 2005 11:44

die datei ist schlicht und ergreifen nicht mitgeliefert.

da du SuSE benutzt kannst du im normalfall über YAST die libarys nach installieren.

Nun kommt das problem... Du benutzt XAMPP, dieses hat eine eigene Directorystruktur.

zwei möglichkeiten, du liest dich in die XAMPP-Developer ein und baust dir ein eigenes XAMPP mit dieser libcurl oder du hast glück und YAST installiert dir diese libcurl und du kannst diese durch einfach herüberkopieren zu xampp lauffähig bekommen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby tribunal89 » 17. April 2005 13:12

Ist ja merkwürdig.
Das verwunderliche ist das ich xampp schon mal laufen hatte, auf den gleichen pc, und die datein davon hab ich auch noch.
Ich hab es nicht mal deinstalliert oder gelöscht. Ich hab nur eines schönen Tages meinen PC neugestartet und dann kam der Fehler. Xampp neuinstalliert und ich hab nun nach langen werkeln wieder den selben Fehler? Wo soll sich denn diese Datei befinden?
tribunal89
 
Posts: 7
Joined: 16. April 2005 21:33

Postby Jan H. Krüger » 17. April 2005 13:18

Liegt üblicherweise hier:
Code: Select all
/usr/lib/libcurl.so.3
Jan H. Krüger
 
Posts: 152
Joined: 24. October 2004 19:42

Postby tribunal89 » 17. April 2005 13:43

Also,
Code: Select all
/usr/lib/libcurl.so.2


Mit ner 3 hinten gibt es die nicht. Und wo bekomme ich die Datei mit einer 3 hinten her?
tribunal89
 
Posts: 7
Joined: 16. April 2005 21:33

Postby tribunal89 » 17. April 2005 13:53

auf welche Weise hast du denn das Update durchgeführt?

Ich habe kein Update durchgeführt. Ich habe Ihn neuinstalliert (entpackt),
da mein alter nicht mehr funktioniert hat. Aber ich habe die Daten von meinen alten Server gesichert.
---------------------------------------------------------------------------------
Ging an Wiedmann, leider wird seine Post nicht mehr angezeigt.

(Der Post ist wieder da, unter deinem. [Wiedmann])
Last edited by tribunal89 on 17. April 2005 14:02, edited 1 time in total.
tribunal89
 
Posts: 7
Joined: 16. April 2005 21:33

Postby Wiedmann » 17. April 2005 13:55

Liegt üblicherweise hier:
Code: Select all
/usr/lib/libcurl.so.3

Da wir einen XAMPP haben, liegt sie hier:
Code: Select all
/opt/lampp/lib/libcurl.so.3

(Wobei das ein Symlink auf die richtige Datei im selben Verzeichnis ist)

BTW:
Starting XAMPP for Linux 1.4.9a...

Starting XAMPP for Linux 1.4.13...

Wie hast du denn das Update durchgeführt?

Ich habe kein Update durchgeführt. Ich habe Ihn neuinstalliert (entpackt),

In dem Archiv "xampp-linux-1.4.13.tar.gz" ist diese Datei jedenfalls an genannter Stelle enthalten.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Jan H. Krüger » 17. April 2005 14:26

Ähm, Wiedmann, da muss ich kurz einlenken.
Ich verwende Xampp 1.4.11. Die Datei liegt nur in dem Pfad welchen ich oben nannte, jedoch nicht unter /opt/lampp/lib/
Es ist *kein* Symlink vorhanden.

Wenn du jetzt sagst diese Datei sollte eigentlich von der Xampp-Installation dorthin kopiert worden sein, dann frage ich mich nun jedoch warum die Datei hier bei mir (Suse 9.2) nur unter /usr/lib abgelegt ist, Xampp jedoch dennoch fröhlich seinen Dienst verrichtet.
Jan H. Krüger
 
Posts: 152
Joined: 24. October 2004 19:42

Postby Wiedmann » 17. April 2005 14:59

Dann erstmal zur Philosophie vom XAMPP:
Er ändert keine Systemdateien. Was immer der XAMPP in der jeweiligen Version unterstützt, befindet sich innerhalb von "/opt/lampp". Shared Libs die der XAMPP benutzt sind dann in "/opt/lampp/lib".

Jan H. Krüger wrote:Ähm, Wiedmann, da muss ich kurz einlenken.
Ich verwende Xampp 1.4.11. Die Datei liegt nur in dem Pfad welchen ich oben nannte, jedoch nicht unter /opt/lampp/lib/
Es ist *kein* Symlink vorhanden.

Da der XAMPP 1.4.11 ("xampp-linux-1.4.11.tar.gz") älter ist als der 1.4.13, gibt es dort erst den Symlink "libcurl.so.2" (--> "libcurl.so.2.0.2") und den Symlink "libcurl.so" (--> "libcurl.so.2"). Diese befinden sich in "/opt/lampp/lib" und werden vom XAMPP benutzt.

Das es in deinem System eine neuere "libcurl.so.3" (bzw. diesen Symlink auf eine neuere "libcurl.so") gibt, die von Anderen bei dir installierten Programmen benutzt werden, kann natürlich schon sein.

Jan H. Krüger wrote:dann frage ich mich nun jedoch warum die Datei hier bei mir (Suse 9.2) nur unter /usr/lib abgelegt ist, Xampp jedoch dennoch fröhlich seinen Dienst verrichtet.

Kann eigentlich nicht sein, ausser du hättest ein Update auf 1.4.11 gemacht und dabei würde was nicht stimmen. Sollten diese Dateien in dem Verzeichnis "/opt/lampp/lib" bei dir tatsächlich nicht vorhanden sein, dann besteht noch die Möglichkeit, dass der XAMPP diese Datei dann in einem deiner Systemverzeichnisse findet. (Vor allem wenn die Programme gegen "libcurl.so" und nicht gegen "libcurl.so.2" gelinkt sind.

Aber wie gesagt. Dein XAMPP arbeitet noch mit der "libcurl.so.2" und neuere Versionen dann mit der "libcurl.so.3".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Jan H. Krüger » 17. April 2005 15:09

Ah, ok. Dank dir.
Dann hat die bei mir vorhandene libcurl.so.3 nichts mit Xampp zu tun und stammt aus anderer Quelle.
Jan H. Krüger
 
Posts: 152
Joined: 24. October 2004 19:42

Postby tribunal89 » 17. April 2005 17:16

Ich versteh nicht ganz, ich weiß jetzt das es die Datei an zwei Orten gibt, aber ich weiß jetzt nicht, was ich mit der Datei machen muss damit mein Xampp-Server wieder geht!
Ich hab nun eine:
Code: Select all
/opt/lampp/lib/libcurl.so.3

und eine:
Code: Select all
/usr/lib/libcurl.so.2

und ich haben bei meinen Server immernoch den Fehler:
Code: Select all
Forbidden


You don't have permission to access / on this server.


Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.0.53 (Unix) mod_ssl/2.0.53 OpenSSL/0.9.7d PHP/5.0.4 DAV/2 mod_perl/1.999.21 Perl/v5.8.6 Server at localhost Port 80

Wenn ich auf ihn zugreifen will.
Was muss ich nun mit diesen Dateien machen, damit ich auf meinen Server komme?
tribunal89
 
Posts: 7
Joined: 16. April 2005 21:33

Postby Wiedmann » 17. April 2005 17:37

Was muss ich nun mit diesen Dateien machen, damit ich auf meinen Server komme?

Nichts, da diese Datei nichts mit denem Fehler zu tun hat.

Bei einem nackten XAMPP in einem leeren Verzeichnis installiert und an dem du noch nichts geändert hast, sollte diese Meldung eigentlich nicht auftauchen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tribunal89 » 17. April 2005 17:58

Nichts, da diese Datei nichts mit denem Fehler zu tun hat.


Der Fehler kommt aber trotzdem, ich habe xampp in ein völlig neues Verzeichnis installiert. Habe aber trotzdem diesen Fehler?
tribunal89
 
Posts: 7
Joined: 16. April 2005 21:33


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests