apache fehler > couldn't grab the accept mutex??

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

apache fehler > couldn't grab the accept mutex??

Postby siryogi » 09. April 2005 12:22

hallo, hab ein Problem mit dem Apache und zwar wird der Apache Prozess nach ca 2 std. einfach beendet

OS: debian 3.0
2x xeon
6gb ram
Ist so n V-server also wies nicht ob das damit was zu schaffen haben könnte

hier ein Auszug aus der error log


Code: Select all
Sat Apr 09 06:36:25 2005] [error] (12)Cannot allocate memory: fork: Unable to fork new process
[Sat Apr 09 06:36:28 2005] [error] (12)Cannot allocate memory: apr_poll: (listen)
[Sat Apr 09 06:46:10 2005] [error] (12)Cannot allocate memory: fork: Unable to fork new process
[Sat Apr 09 06:46:15 2005] [error] (12)Cannot allocate memory: apr_poll: (listen)
[Sat Apr 09 06:46:16 2005] [error] (12)Cannot allocate memory: apr_poll: (listen)
[Sat Apr 09 06:46:18 2005] [error] (12)Cannot allocate memory: apr_poll: (listen)
[Sat Apr 09 06:46:26 2005] [error] (12)Cannot allocate memory: fork: Unable to fork new process
[Sat Apr 09 06:46:35 2005] [error] (12)Cannot allocate memory: apr_poll: (listen)
[Sat Apr 09 06:46:36 2005] [emerg] (12)Cannot allocate memory: couldn't grab the accept mutex
[Sat Apr 09 06:46:36 2005] [error] (12)Cannot allocate memory: fork: Unable to fork new process
[Sat Apr 09 06:46:46 2005] [alert] Child 31809 returned a Fatal error...\nApache is exiting!
[Sat Apr 09 06:46:46 2005] [emerg] (43)Identifier removed: couldn't grab the accept mutex
[Sat Apr 09 06:46:46 2005] [emerg] (43)Identifier removed: couldn't grab the accept mutex
[Sat Apr 09 06:46:46 2005] [emerg] (43)Identifier removed: couldn't grab the accept mutex
siryogi
 
Posts: 9
Joined: 02. October 2004 00:30

Postby deepsurfer » 10. April 2005 09:21

Erster LINK in ergebnis liste

Hiervon den ersten LINK nehmen


hast du in etwa damit auch etwas zutun ??? Ein PERLscript das auf MySQL zugrif arbeitet ????
Last edited by deepsurfer on 11. April 2005 08:51, edited 1 time in total.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby siryogi » 10. April 2005 23:57

nein, hab kein perl script...nur php das komisch jedoch ist das es unter win32 ohne Probleme geht … nun gut scheint also am script und linux, apache, xampp kA was zu ligen….

und den text in googel ein copyn kann ich auch, jedoch konnte mir das leider nicht so recht helfen, deswegen hier der post!
siryogi
 
Posts: 9
Joined: 02. October 2004 00:30

Postby Oswald » 11. April 2005 00:21

Vermute zu wenig Speicher: Cannot allocate memory

Das gibt es recht oft bei vservern.

Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby siryogi » 11. April 2005 13:25

die kieste hat laut systemsats2 noch gute 1 gig von 6 gig frei *g

..aber es scheint an apach2 gelegen zu haben hab das ganze mal mit Apache 1.3.33 jetzt am laufen und das geht nu schon fast 24h gut :-)
*3x aufholzklopf*
siryogi
 
Posts: 9
Joined: 02. October 2004 00:30

Postby Oswald » 11. April 2005 13:30

siryogi wrote:die kieste hat laut systemsats2 noch gute 1 gig von 6 gig frei *g


Richtig. Aber das hat bei vservern so gut wie nix zu bedeuten! Das ist ja das gemeine bei diesen vservern. ;)

Aber gut, dass es jetzt läuft.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest