xampp mit kernel 2.6.9

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

xampp mit kernel 2.6.9

Postby Francois » 30. March 2005 21:06

Hallo
Ich habe das follegendes Problem mit phpMyAdmin mit ein Debian 2.6.9 Kernel (package kernel-image-2.6.9-2-k7_2.6.9-5_i386.deb) und mit xampp 1.4.10a:

- das links Teil in phpMyAdmin zeigt
Code: Select all
#2002 - Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)

der recht Teil sieht gut aus.
- die lätzte linien aus dmesg sind:
Code: Select all
NET: Registered protocol family 10
Disabled Privacy Extensions on device c031e360(lo)
IPv6 over IPv4 tunneling driver

- der xterm von welches xampp gestart war, gibt:
Code: Select all
Unknown HZ value! (92) Assume 100.

- tail -10 /home/fra/opt/lampp/var/mysql/arabis.err gibt
Code: Select all
Number of processes running now: 0
050315 21:29:03  mysqld restarted
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.1.7-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306  Source distribution
libgcc_s.so.1 must be installed for pthread_cancel to work
Number of processes running now: 0
050315 21:29:11  mysqld restarted
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.1.7-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306  Source distribution

Mit kernel 2.4.18 gibt die gleiche xampp kein Problem.

Diese Probleme sind schlecht wenn ein Password zu mysql bestimmt ist, weil mit reload wird man ausgeworfen sein...

Danke für jene Hinweis

François
Francois
 
Posts: 12
Joined: 20. December 2004 18:31

Postby Oswald » 31. March 2005 09:18

Hallo François!

Das sieht ja erst mal alles ganz gut aus. Ich wundere mich, dass es nicht funktioniert. Kannst Du bitte mal den folgenden Befehl aufrufen und sagen was der ausgibt.

ls -l /opt/lampp/var/mysql/mysql.sock

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Wiedmann » 31. March 2005 09:28

libgcc_s.so.1 must be installed for pthread_cancel to work

Diese Datei ist im XAMPP-Paket nicht mit drin.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Oswald » 31. March 2005 10:39

Huhu Wiedmann!

Die Meldung kommt durch das Restarten des MySQLs. Sollte den Betrieb von MySQL eigentlich nicht beeinflussen.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Francois » 31. March 2005 20:39

Kai 'Oswald' Seidler wrote:Hallo François!

Das sieht ja erst mal alles ganz gut aus. Ich wundere mich, dass es nicht funktioniert. Kannst Du bitte mal den folgenden Befehl aufrufen und sagen was der ausgibt.

ls -l /opt/lampp/var/mysql/mysql.sock

Liebe Grüße
Oswald


Hallo Kai

ls -l /opt/lampp/var/mysql/mysql.sock gibt
srwxrwxrwx 1 nobody nogroup 0 2005-03-30 20:18 /opt/lampp/var/mysql/mysql.sock

Mit 2.4.18 oder 2.6.9 ist es das gleiches

François

Nur eingie Bemerkungen:
Das problem liegt meistens mit Mozilla und phpMyadmin: das linkes Part ist mit mysql nicht verrbunden...

Mit Galeon ist es nicht so schlimm, aber es ist still Fehler wie " mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /opt/lampp/phpmyadmin/libraries/dbi/mysql.dbi.lib.php on line 118"

Die Unknown HZ value waren weil procps zu alt war. Mit 3.2.1 sind sie weg.
Gruss
François
Francois
 
Posts: 12
Joined: 20. December 2004 18:31


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests