Virtual Hosts - Warnung "... overlap on port 80"

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Virtual Hosts - Warnung "... overlap on port 80"

Postby Sabine » 29. March 2005 11:34

Auf dem Linux-Xampp sind zwei VirtualHosts wie folgt definiert:

Code: Select all
<VirtualHost *:80>
      DocumentRoot "/opt/lampp/htdocs"
   ServerName inet
       AddType text/html .html
       AddOutputFilter INCLUDES .html
      AddHandler server-parsed .html
       <Directory "/opt/lampp/htdocs/">
   Options ExecCGI Includes Indexes MultiViews
   AllowOverride None
   Order allow,deny
   Allow from all
   </Directory>
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "/opt/lampp/htdocs/webname"
    ServerName webname
    ErrorLog /opt/lampp/logs/error_sisoft.log
    CustomLog /opt/lampp/logs/access_sisoft.log common
    AddType text/html .html
    AddOutputFilter INCLUDES .html
    AddHandler server-parsed .html
    <Directory "/opt/lampp/htdocs/webname">
   Options ExecCGI Includes Indexes MultiViews
   AllowOverride AuthConfig Limit
   Order allow,deny
   Allow from all
    </Directory>
</VirtualHost>


Und jedesmal, wenn der Lampp neu gestartet wird, wirft er folgende Warnmeldung aus:

[warn] _default_ VirtualHost overlap on port 80, the first has precedence

Und prompt kriege ich im Browser natürlich immer nur EIN Web zu sehen, obwohl ich meiner hosts-Datei (WinXP-Prof) beide eingetragen habe.

Merkwürdigerweise funktionieren die VHosts auf meinem lokalen, älteren Xampp unter XP absolut problemlos *wunder*.


[/code]
Sabine
 
Posts: 5
Joined: 29. March 2005 08:44

Postby Wiedmann » 29. March 2005 11:47

Dir fehlt die folgende Zeile vor den VHost-Definitionen:
Code: Select all
NameVirtualHost *:80


ServerName solltest du auch so schreiben:
Code: Select all
ServerName inet:80
ServerName webname:80

In der "ssl.conf" dann dem entsprechend mit ":443".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sabine » 29. March 2005 12:00

Wiedmann wrote:Dir fehlt die folgende Zeile vor den VHost-Definitionen:
Code: Select all
NameVirtualHost *:80


*Aua* - betriebsblind gewesen...


Wiedmann wrote:ServerName solltest du auch so schreiben:
Code: Select all
ServerName inet:80
ServerName webname:80

In der "ssl.conf" dann dem entsprechend mit ":443".


Danke schön!
Sabine
 
Posts: 5
Joined: 29. March 2005 08:44


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests