zum 100.000 Mal - httpd.conf und htaccess :-)

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

zum 100.000 Mal - httpd.conf und htaccess :-)

Postby Sabine » 29. March 2005 09:13

Moin, Forum ;)

bevor ich mich entschied, diese Frage zu stellen, habe ich das Forum selbstverständlich nach dem Stichwort "htaccess" durchsucht - aber leider bis jetzt keine Lösung für mich gefunden. :(

In unserem Unternehmen wurde vor 3 Wochen die aktuelle XAMPP-Version auf einem Debian-System installiert. (Ist noch nicht in der DMZ, Zugriff nur von "innen" (Server hat lokale IP-Adresse 192.168.x.x)
Klappt soweit alles recht zufriedenstellend - bis auf den Verzeichnisschutz mit htaccess.

So sieht meine htaccess-Datei aus:

# .htaccess-Datei fuer Web-Verzeichnis /kservice
AuthType Basic
AuthName "Kundenservice"
AuthUserFile /opt/lampp/htdocs/xxx/manage/.htusers
AuthGroupFile /opt/lampp/htdocs/xxx/manage/.htgroups
require group Kunden

<Limit GET POST>
order deny,allow
require valid-user
</Limit>


so die .htgroups:
#Alle Kunden
kunden: xxx yyy zzz
- und jede Menge weitere Namen

und so die .htusers:
kundenname: paßwort (selbstverständlich mit crypt verschlüsselt)


Tja - wenn ich dann das geschützte Verzeichnis /kservice im Browser aufrufe - dann "latscht" der da einfach rein, ohne jegliche Paßwortabfrage :o

In der httpd.conf sind vielleicht noch folgende Einträge relevant für eine hilfreiche Antwort:
DocumentRoot "/opt/lampp/htdocs"
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory "/opt/lampp/htdocs">
Options Indexes FollowSymLinks ExecCGI Includes
AllowOverride All
Order allow,deny
Deny from all
</Directory>
DirectoryIndex index.html index.html.var index.php index.php3 index.php4 default.htm default.html
AccessFileName .htaccess
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>
.
.
.
<VirtualHost *:80>
DocumentRoot "/opt/lampp/htdocs"
ServerName localhost
</VirtualHost>



<VirtualHost *:80>
DocumentRoot "/opt/lampp/htdocs/webname"
ServerName webname
ErrorLog /opt/lampp/logs/error_web.log
CustomLog /opt/lampp/logs/access_web.log common
AddType text/html .html
AddOutputFilter INCLUDES .html
AddHandler server-parsed .html
<Directory "/opt/lampp/htdocs/webname">
Options ExecCGI Includes Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>
</VirtualHost>


Wo steckt der Teufel im Detail???

Vielen Dank - Sabine
Sabine
 
Posts: 5
Joined: 29. March 2005 08:44

Postby PF4 » 29. March 2005 10:19

<VirtualHost *:80>
DocumentRoot "/opt/lampp/htdocs/webname"
ServerName webname
ErrorLog /opt/lampp/logs/error_web.log
CustomLog /opt/lampp/logs/access_web.log common
AddType text/html .html
AddOutputFilter INCLUDES .html
AddHandler server-parsed .html
<Directory "/opt/lampp/htdocs/webname">
Options ExecCGI Includes Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

Da steckt der Fehler.
Setze das mal auf All
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby Wiedmann » 29. March 2005 10:20

<VirtualHost *:80>
DocumentRoot "/opt/lampp/htdocs/webname"
ServerName webname
ErrorLog /opt/lampp/logs/error_web.log
CustomLog /opt/lampp/logs/access_web.log common
AddType text/html .html
AddOutputFilter INCLUDES .html
AddHandler server-parsed .html
<Directory "/opt/lampp/htdocs/webname">
Options ExecCGI Includes Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

Gesetz dem Fall du möchtest die von dir gepostete ".htaccess"-Datei innerhalb dieses VHosts einsetzten, müsstest du die gekennzeichnete Zeile folgendermassen ändern:
Code: Select all
AllowOverride AuthConfig Limit
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sabine » 29. March 2005 11:02

Herzlichen Dank Euch beiden - es funzt!

*freu* - jetzt weiß ich wieder ein bissl mehr als unser Netzwerk-Admin, der eigentlich für den Internet-Server zuständig ist (sein sollte?)
Sabine
 
Posts: 5
Joined: 29. March 2005 08:44

Postby deepsurfer » 29. March 2005 15:33

bevor ich mich entschied, diese Frage zu stellen, habe ich das Forum selbstverständlich nach dem Stichwort "htaccess" durchsucht - aber leider bis jetzt keine Lösung für mich gefunden


Wie hast du denn die Suchfunktion hier im Forum benutzt ???

wenn ich hingehe und im suchwort .htaccess und dann der SuFU noch sage das diese nur im XAMPP für Linux schauen soll erhalte ich Antworten liste, schon der siebte (derzeit) hat schon komplette Lösung für dich parat. Mit allen Hinweisen die du hier bekommen hast.


Versteh mich jetzt nicht falsch und fühle dich nicht angegriffen, bin nur neugirig wie Du gesucht hast.

Selbst der HTML-Almanach "SELFHTML" beschreibt diesen Vorgang in allen einzelheiten, sogar der Hinweiss auf die COnfiguration wird erklärt.

http://de.selfhtml.org/servercgi/server/htaccess.htm
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests