PHP5 als CGI, Error 500, premature end of scripts ...

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

PHP5 als CGI, Error 500, premature end of scripts ...

Postby smat » 17. March 2005 16:20

ich arbeite nun seit zwei tagen an der httpd.conf, bekomme aber php5 als cgi nicht zum laufen ...

in dem apache error log steht für jeden error 500 einmal
... [error] ... Premature end of script headers: php-5.0.3

mein eintrag in der httpd.conf sieht so aus:
>>
Code: Select all
# PHP5 /opt/lampp/bin/php-5.0.3
<Directory /opt/lampp/bin>
   Options ExecCGI FollowSymLinks
   AllowOverride None
</Directory>

ScriptAlias /php5bin /opt/lampp/bin

<Directory "/var/www">
Action php5-cgi /php5bin/php-5.0.3
AddHandler php5-cgi .php5
</Directory>

>>

bitte, bitte ....
das macht mich noch wahnsinnig, hatte das noch nie ...
wenn noch irgendwelche nützlichen angaben fehlen, reiche ich die sofort nach - und vielen dank für eure hilfe!!!!!

- smat
php4 hab ich als modul laufen ...
smat
 
Posts: 3
Joined: 17. March 2005 16:14

Postby deepsurfer » 17. March 2005 16:45

..
Last edited by deepsurfer on 27. April 2005 12:36, edited 1 time in total.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 17. March 2005 16:55

bekomme aber php5 als cgi nicht zum laufen ...

Beim XAMPP für Linux ist PHP nicht als CGI dabei.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby smat » 17. March 2005 18:39

doch, /opt/lampp/bin/php-5.0.3 ??
oder was ist dieses php-5.0.3 ?
und wenn es nicht dabei ist, wie schaffe ich es beide parallel laufen zu lassen, wo bekomme ich das passende php-5.0.3 her, mit der gleichen konfiguration?
smat
 
Posts: 3
Joined: 17. March 2005 16:14

Postby Wiedmann » 17. March 2005 19:15

oder was ist dieses php-5.0.3 ?

warum schaust nicht selbst? ;-)
Code: Select all
/opt/lampp/bin/php-5.0.3 -v


wo bekomme ich das passende php-5.0.3 her,

Wenn du PHP als CGI brauchst, dann müsstest du das dir selbst compilieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby smat » 17. March 2005 19:31

was mir grad einfällt, die personen hinter XAMPP müssten ja die cgi-version haben, könnte ich vielleicht mal eine mail schreiben dass die mir diese senden?
oder haben die diese nicht?
smat
 
Posts: 3
Joined: 17. March 2005 16:14


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest