xampp startet jedoch die zweite....

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

xampp startet jedoch die zweite....

Postby allie » 14. March 2005 12:55

hallo zusammen,

xampp startet mit apache und mysql. webseiten laufen, nur leider bekomme ich keinen connect mit mysql-db. ich finde den fehler nicht. phpmyadmin kann ich öffnen, db anlegen, bearbeiten usw... versuche dann über dw eine mysql verbindung aufzubauen - leider ohne erfolg...

ohne xampp läuft alles. apache und mysql mit connect usw..

wer kann mir helfen.. komme leider nicht mehr weiter..

viele grüsse
allie
allie
 
Posts: 12
Joined: 10. March 2005 14:52

Postby Stefan » 14. March 2005 14:45

Mahlzeit,

nur leider bekomme ich keinen connect mit mysql-db.

phpmyadmin kann ich öffnen, db anlegen, bearbeiten usw...

Na wie jetzt? Geht doch.
versuche dann über dw

Dreamweaver? Also wenn Du da mal nichts in der Hilfe findest, kann Dir hier auch keiner helfen.
ohne xampp läuft alles. apache und mysql mit connect usw..

Du wollstest schreiben, _ohne_ DW geht alles, oder?
wer kann mir helfen.. komme leider nicht mehr weiter..

Mehr als die Information "host/user/pass/port" wirst Du sicher nicht benötigen um DW zu füttern. Die Infos hast Du, jetzt mußt Du halt mal die Hilfe fragen wie das einzutragen ist.


ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Re

Postby allie » 14. March 2005 17:31

Danke für die schnelle Hilfestellung. Es liegt aber nicht an DW. Es liegt irgendwo noch ein Rechteproblem auf Linux vor, d.h. Irgendwo habe ich den Xampp noch nicht richtig konfiguriert.. Leider keine Ahnung wo...

Angeblich hat mein Rechner keine Erlaubnis auf den Apache zu greifen, bzw. einen MySQL connect durchzuführen..
allie
 
Posts: 12
Joined: 10. March 2005 14:52

Postby deepsurfer » 14. March 2005 18:00

Wie Stefan schon Zitiert hat, bist du mit deiner Erklärung etwas verwirrend unterwegs. Zum einen schreibst du das XAMPP geht aber irgendwie doch nicht und dann läuft alles ohne XAMPP......


Nungut, ich interpretiere das mal so.

Du hast ein Linuxsystem (wäre gut zu wissen welche Distribution du benutzt), darauf funktioniert der Apache und MySQL einwandfrei.
ohne xampp läuft alles. apache und mysql mit connect usw..




Nachdem du XAMPP als Root bei Dir installiert hast funktioniert es nicht richtig.
Hier würde ich dich fragen ob Fehlermeldungen bei starten des XAMPP auf dem Monitor erscheinen. !?!?!?

Denn nach meinem Wissen müssten einige Meldungen erscheinen, denn ich behaupte hier mal das du den Apachen und dem MySQL-Server von deiner Linux-Distribution nicht gestopt hast.

Wie Du merkst sind durchaus eiige Dinge zu bedenken wenn man XAMPP auf ein vollständiges Linuxsystem Installiert.

Meld dich nochmal und beschreib ein klein wenig genauer wie du mit XAMPP arbeitest.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Stefan » 14. March 2005 20:02

Servus,

achso...., ich hab nicht aufgepaßt, hier ist ja "XAMPP für Linux"... DW!=Linux
Da sich Dreamweaver nicht im "localhost" Bereich des Servers befindet, darf der Benutzer, mit dem Du Dich verbinden willst, nicht zugreifen.

ähhh..... aber phpmyadmin lief?
Vermutlich lief die vorinstallierte Version vom PMA, richtg?
Und nach starten des lampp war dann Essig mit Zugriff, richtig?

Das Verbindungsproblem kannst Du, nachdem Du die Serverumgebung in Ordnung gebracht hast, leicht lösen, in dem Du dem richtigen User(welcher sqlserver läuft wohl?) einfach das richtige Recht an richtigen Fleck verpasst.

Vielleicht solltest Du auch einfach mal mit der vorinstallierten Umgebung üben, den die sollte im Gegensatz zum lampp wenigsten einigermaßen sicher vorkonfiguriert sein.

ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

ok.ok....gelobe besserung

Postby allie » 15. March 2005 11:47

nun, zunächst ein dickes sorry....

ihr habt ja recht.. alles recht dürftig mit meinen aussagen... daran sieht man die verzweiflung... :-)

ok, das ganze mal von vorne...

es war die zeit vor xampp. linux 9.2, apache2, php4.3.8. darunter läuft alles. bisher hatte ich alles ohne xampp. auf xampp bin ich nur deshalb gekommen, weil ich nun von einer mysql db auf eine oracle db gehen muss... darin habe ich bisher noch keine erfahrung und bin über xampp gestolpert. vielleicht befinde ich mich damit auch auf einem total falschen dampfer mit meiner oracleanbindung. (für andere vorschläge bin ich an dieser stelle natürlich dankbar)
bevor ich xampp starte halte ich natürlich zunächst meine "alten" (apache, mysql)-dienste an. danach starte ich xampp. start erfolgt ohne fehlermeldungen. er startet schön durch. danach gelange ich immerhin auf die index.php von xampp, kann darüber auch auf phpmyadmin zugreifen. bevor ich mich nun an die anbindung von oracle mache, wollte ich die "alten" verbindung testen. sprich zugriff auf meine bestehenden mysql-db. da liegt nun der hund begraben...

bei connect mit dw (ich arbeite nun mal mit diesem ding, da ich es gewohnt bin und einigermaßen kenne - bin offen für bessere programme) kommt diese fehlermeldung:

"1130#HY000 Host "linux.site" is not allowed to connect to this MySQL server"

vielleicht bin ich einfach nur blind, oder sehe den wald vor lauter bäumen nicht mehr...

vielen dank für die hilfe....
allie
 
Posts: 12
Joined: 10. March 2005 14:52

Postby Stefan » 15. March 2005 14:18

Servus,

"1130#HY000 Host "linux.site" is not allowed to connect to this MySQL server"

Der user, mit dem Du Dich verbinden willst, darf wahrscheinlich nur über "localhost" zugreifen, da Du aber "linux.site" als Host in den Verbindungsdaten(DW) stehen hast, wird die Verbindung abgelehnt.
DB "mysql" -> Tabelle "user" -> "host"

Zu dem ganzen anderen Rest kann ich Dir keine Empfehlung abgeben, ist einfach zu komplex. Ich weis ja nicht, wie es bei Dir aussieht, vhosts, Datenbanken die erhalten bleiben sollen etc. Du könntest auch die "alten" Dienste beibehalten, und nur den Apache aus dem lampp laufen lassen, natürlich mit der conf des alten bzw. einer angepassten neuen. Oder Du kompilierst php mit den passenden oracle schaltern neu und lässt es mit dem lampp bleiben. Wäre nicht die schlechteste Lösung. Wahrscheinlich weiß jemand anderst darüber allerdings besser bescheid als ich.

Viel Erfolg
ciao, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby deepsurfer » 15. March 2005 16:21

mit dem DW fehler solltest du mit der Erklärung von Stefan zurecht kommen...oder ?????


Mit dem Oracle.... jo, etwas sehr komplex, aber benutze bitte mal die Suchfunktion dieses Forum, denn soweit ich mich erinnere sind hier schon mehrere dabei mittels XAMPP auf Oracle-DB zuzugreifen.
XAMPP unterstützt die verbindung zu Oracle, aber ich meine mich zu erinnern, das bei der Installation von Oracle selber etwas beachtet werden muss.
Schau dazu aber wie gesagt in die SuFU und melde dich bei den Usern die damit schon arbeiten bzw. einen Lösungsweg durchgehen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

oweia....

Postby allie » 16. March 2005 08:22

habt vielen dank.. nun läuft das ding auch.. :-)

ich sags ja, der wald vor lauter bäumen ward nimmer geseh´n.

dann schaun wir mal, was das teil so alles kann und hoffen auf eine verbindung mit meiner oracle-db.

auf jedenfall ein dickes dankeschööön und beim nächsten mal drücke ich mich auch genauer aus...

viele grüsse
allie
allie
 
Posts: 12
Joined: 10. March 2005 14:52


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 7 guests