Merkwürdige Probleme auf einem Debian-System

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Merkwürdige Probleme auf einem Debian-System

Postby mcp » 20. February 2005 12:08

Ich nutze XAMPP für Linux bereits auf einem lokalen Rechner mit Trustix als Basis und bin sehr zufrieden damit. Nun habe ich seit kurzem einen Rootserver bei Alturo, den ich auf Debian (Woody) umgestellt habe (ich hätte gerne wieder Trustix genommen, aber das über die Recovery-Konsole zu installieren übersteigt leider meine Kenntnisse).

Wenn ich jetzt XAMPP auf dem mit http://linux.roothell.org/debian-rootie/ frisch installierten System starte, kommt es zu ganz komischen Fehlern (MySQL war vor dem einspielen von XAMPP noch nicht drauf):

- /opt/lampp/lampp security meldet unter anderem folgendes:

XAMPP: MySQL is accessable via network.
XAMPP: Normaly that's not recommended. Do you want me to turn it off? [yes]
XAMPP: Turned off.
XAMPP: Stopping MySQL...
XAMPP: A MySQL daemon is already running.
XAMPP: MySQL has to run before I can check the security.

Anscheinend klappt irgendwas mit dem Stoppen nicht richtig ...

Außerdem frägt mich das Skript nicht, ob ich das MySQL-Root-Passwort setzen möchte.

- /opt/lampp/lampp stopftp stoppt ProFTP nicht, den Prozess kann ich nur per kill abschießen

- /opt/lampp/lampp stop ergibt:

Stopping XAMPP for Linux 1.4.11...
XAMPP: Stopping Apache with SSL...
XAMPP: XAMPP-MySQL is not running.
XAMPP stopped.

ps -aux zeigt mir aber drei mysql-Prozesse an:

nobody 523 0.0 2.0 25064 5172 pts/0 S 11:33 0:00 [mysqld]
nobody 525 0.0 2.0 25064 5172 pts/0 S 11:33 0:00 [mysqld]
nobody 526 0.0 2.0 25064 5172 pts/0 S 11:33 0:00 [mysqld]

- wenn ich meinen Webserver mit einem Browser aufrufe, kommt die Splash-Seite (/xampp/splash.php), wo ich die Sprache auswählen kann, egal worauf ich klicke, die Seite refresht sich anscheinend aber nur und ich komme nicht weiter

Irgendwas stimmt hier also gar nicht. Hat jemand eine Idee?

Edit: Das vollständige error_log:

[Sun Feb 20 11:33:29 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sun Feb 20 11:33:30 2005] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 20 11:33:30 2005] [notice] Digest: done
[Sun Feb 20 11:33:31 2005] [notice] Apache/2.0.52 (Unix) mod_perl/1.99_17 Perl/v5.8.4 mod_ssl/2.0.52 OpenSSL/0.9.7d PHP/5.0.3 DAV/2 configured -- resuming normal operations
[Sun Feb 20 11:47:25 2005] [notice] caught SIGTERM, shutting down
[Sun Feb 20 11:54:12 2005] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sun Feb 20 11:54:12 2005] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 20 11:54:12 2005] [notice] Digest: done
[Sun Feb 20 11:54:13 2005] [notice] Apache/2.0.52 (Unix) mod_perl/1.99_17 Perl/v5.8.4 mod_ssl/2.0.52 OpenSSL/0.9.7d PHP/5.0.3 DAV/2 configured -- resuming normal operations
mcp
 
Posts: 3
Joined: 20. February 2005 11:48

Postby Kristian Marcroft » 20. February 2005 13:30

Hi,

zu dem Problem mit MySQL kann ich nichts sagen...
Aber zum Problem mit dem FTP.
Der FTP den du killst ist nicht der ProFTPd.
Bei debian wird standardmässig der FTP via inetd gestartet...

Um das abzustellen, musst du in der /etc/inetd.conf die Zeile auskommentieren bei der der FTP aktiviert wird.
Einfach ein # davor setzen.

Anschliessend inetd neustarten mit /etc/init.d/inetd restart

Dann den FTP von LAMPP starten und dann sollte alles wie gewohnt funzen.

btw. XAMPP ist nicht für den Rootserver geeignet!
Bitte überdenke das ganze nochmal!
Machs lieber so wie www.debianhowto.de es beschreibt!
1. sicherer
2. lernst auch noch was dabei...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby mcp » 20. February 2005 14:23

Hallo,

erstemal vielen Dank für deine Antwort! In meiner inetd.conf steht allerdings gar kein Eintrag zu ftp:

Code: Select all
# /etc/inetd.conf:  see inetd(8) for further informations.
#
# Internet server configuration database
#
#
# Lines starting with "#:LABEL:" or "#<off>#" should not
# be changed unless you know what you are doing!
#
# If you want to disable an entry so it isn't touched during
# package updates just comment it out with a single '#' character.
#
# Packages should modify this file by using update-inetd(8)
#
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
#
#:INTERNAL: Internal services
#echo           stream  tcp     nowait  root    internal
#echo           dgram   udp     wait    root    internal
#chargen        stream  tcp     nowait  root    internal
#chargen        dgram   udp     wait    root    internal

#:STANDARD: These are standard services.


#:MAIL: Mail, news and uucp services.
smtp            stream  tcp     nowait  mail    /usr/sbin/exim exim -bs

#:INFO: Info services
#<off># ident           stream  tcp     wait    identd  /usr/sbin/identd        identd

# run this only on machines acting as "boot servers."

#:RPC: RPC based services

#:HAM-RADIO: amateur-radio services

#:OTHER: Other services


Bevor ich XAMPP versucht habe, hatte ich zuerst einen Mix aus einer Anleitung aus dem Rootforum ( http://www.rootforum.de/forum/viewtopic.php?t=16510 ) und den Debianhowtos probiert. Irgendwo kam ich jedoch nicht weiter, sodass ich XAMPP ausprobieren wollte, das lokal auf Trustix ja ausgezeichnet und absolut problemlos läuft. Aber selbst nach mehreren Neuinstallationen bleibe ich jedesmal an diesem mysteriösen Verhalten von XAMPP stecken ...

Aber du hast schon recht, ich werde es nochmal auf dem Debianhowto-Weg probieren. Allerdings bin ich immer noch neugierig, wieso XAMPP hier so rumspinnt. Wenn also noch jemand Ideen oder Hinweise hat, immer her damit. :)
mcp
 
Posts: 3
Joined: 20. February 2005 11:48

Postby Kristian Marcroft » 20. February 2005 14:55

Hi,

schau mal ob du eine xinetd.conf hast?
und ob da evtl was von FTP drin steht?
Wenn nein, wäre die Ausgabe von

ps aux | grep ftp

mal interessant, wenn der FTP angeblich läuft...

bezüglich MySQL könntest mal:

ps aux | grep mysql

ausprobieren.. ob das ein output erzeugt...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby mcp » 20. February 2005 21:05

Zu spät, ich habe deinen Rat befolgt, mich bei diesem Projekt von XAMPP verabschiedet und acker mich nun wieder durch die Debianhowtos. :) Aber vielen Dank nochmal!
mcp
 
Posts: 3
Joined: 20. February 2005 11:48


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests