CGI Fehlermeldung you don't have permission.....

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

CGI Fehlermeldung you don't have permission.....

Postby superbike » 14. February 2005 14:42

Hallo Leute,
meine CGI laufen nicht (sonst Website einwandfrei):
    You don't have permission to access /best_send/bestellung.cgi on this server.
    Apache/2.0.52 (Unix) mod_perl/1.99_17 Perl/v5.8.4 mod_ssl/2.0.52 OpenSSL/0.9.7d PHP/5.0.3 DAV/2 Server at www.arastar.ch Port 80
CGI Scrip der Website unter :/webhosts/arastar/htm_docs/best_send/bestellung.cgi
(VHost entsprechend definiert in httpd.conf)

Apache restart und Aufruf der CGI via Website ergeben folgende Meldungen in /opt/lampp/logs/error_log:
    [Mon Feb 14 13:44:12 2005] [notice] Apache/2.0.52 (Unix) mod_perl/1.99_17 Perl/v5.8.4 mod_ssl/2.0.52 OpenSSL/0.9.7d PHP/5.0.3 DAV/2 configured -- resuming normal operations
    [Mon Feb 14 13:44:58 2005] [error] [client 192.168.1.119] Options ExecCGI is off in this directory: /webhosts/arastar/htm_docs/best_send/bestellung.cgi, referer: http://www.arastar.ch/bestellung.htm

Frage: muss ich da noch etwas in httpd.conf bezüglich cgi anpassen oder liegts an Linux-Dateirechte (bestellung.cgi rwxrwxr-x)?

Danke für Eure Hilfe!
User avatar
superbike
 
Posts: 38
Joined: 17. November 2004 15:17

Postby PF4 » 14. February 2005 14:47

Hi,
was gibt an
Options ExecCGI is off in this directory ned zu verstehen?
^^^^^^^^^^^^^^^^
in die Direktive des Verz.
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby superbike » 14. February 2005 14:56

ja und wo wie schalt ich die den ON ?
User avatar
superbike
 
Posts: 38
Joined: 17. November 2004 15:17

Postby Wiedmann » 14. February 2005 15:17

Sconmal in die Apache-Doku geschaut?

Ansonsten wird der Apache über die Datei httpd.conf oder .htaccess konfiguriert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby superbike » 14. February 2005 15:39

ok, funktioniert, nachdem ich in httpd.conf beim entsprechenden VHost die Option +ExecCGI :P eingefügt habe.
Code: Select all
<VirtualHost *:80>
DocumentRoot /webhosts/arastar/htm_docs
ServerName www.arastar.ch
<Directory "/webhosts/arastar/htm_docs">
allow from all
Options +Indexes +ExecCGI
</Directory>
</VirtualHost>

PF4, Deine Anregung war etwas gar kurz :? für ein Nowbody wie mich, hat mich dann aber mit dem linuxforum zusammen doch auf die richtige Fähret geführt.
thanks to all
User avatar
superbike
 
Posts: 38
Joined: 17. November 2004 15:17


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests