proftp startet eim Systemstart immer automatisch

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

proftp startet eim Systemstart immer automatisch

Postby alphaATquantum » 24. August 2020 23:53

Hallo liebe Helfer,

Habe das Apache Paket soweit erfolgreich installiert, Apache nach meinen wünschen eingerichtet sowie MariaDB.
Aber leider macht mir ProFTP ein Problem das mich ziemlich nervt.

Wenn ich nach Systemstart Apache, DB, Ftp starten möchte per konsole läuft ProFTP bereits !
Wenn ich mich von einem anderen gerät mit mein Systembenutzer anmelde(FTPClient) werden sogar alle Einstellung der config ignoriert die ich unter der conig-datei unter den bekannten Apachepfaden angegeben habe, also DocumentRoot wird ignoriert und ich lande per ftp client in dem Root verzeichnis meines Systems.

Nach Systemstart muss ich proftp erstmal manuell killen. Bevor ich alles sauber starten kann und proftp so funktioniert wie ich es eingerichtet habe.

Ich benutze mein lieblings derivat Kubuntu in der Version 20.04 und Xampp 7.4.9.0x64

Ich möchte um Hilfe bitten da ich mit meinem aktuellen Wissen diese Problem nicht lösen kann und hoffe daraus zu lernen.

Danke schon mal für eure Mühe!

Gruss
alphaATquantum
alphaATquantum
 
Posts: 2
Joined: 24. August 2020 23:31
XAMPP version: 7
Operating System: Kubuntu 20.04

Re: proftp startet eim Systemstart immer automatisch

Postby Nobbie » 25. August 2020 10:59

alphaATquantum wrote:Wenn ich nach Systemstart Apache, DB, Ftp starten möchte per konsole läuft ProFTP bereits !


Wahrscheinlich hast Du in Kubuntu bereits ProFTP installiert. Schau doch mal im Prozessverzeichnis nach ("ps -fe" in einer Shell), aus welchem Pfad proftpd gestartet wird, das wird wahrscheinlich nicht aus /opt/lampp sein sondern irgendwo /usr/bin oder /usr/sbin oder oder oder. Wenn Du es gefunden hast, musst Du Dich entscheiden, welchen ProFTP Du benutzen willst, den von Xampp oder den von Kubuntu. Im Prinzip ist das eigentlich egal, aber wenn Du Xampp als Paket starten willst, ist es vielleicht einfacher, das Kubuntu ProFTP Paket zu deinstallieren.

alphaATquantum wrote:Wenn ich mich von einem anderen gerät mit mein Systembenutzer anmelde(FTPClient) werden sogar alle Einstellung der config ignoriert die ich unter der conig-datei unter den bekannten Apachepfaden angegeben habe, also DocumentRoot wird ignoriert und ich lande per ftp client in dem Root verzeichnis meines Systems.


Das klingt jetzt etwas wild. FTP und Apache haben rein gar nichts miteinander zu tun und der ftp client hat keinerlei Kenntnisse von einem DocumentRoot. Damit Apache und FTP harmonieren, musst Du die entsprechenden Konfigurationsdatein für beide Tools anpassen. Für Apache bist Du schon fertig, jetzt musst Du noch ProFTP anpassen. Das wird wahrscheinlich in /etc/proftpd.d (oder ähnlich, weiß ich nicht auswendig) für Kubuntu resp. in /opt/lampp/etc/proftpd.d für Xampp ProFTP geschehen. Wie gesagt, Du kannst aber nur einen der beiden FTPs benutzen.

alphaATquantum wrote:Nach Systemstart muss ich proftp erstmal manuell killen. Bevor ich alles sauber starten kann und proftp so funktioniert wie ich es eingerichtet habe.


s.o. - auch das spricht sehr dafür, dass Du schon in Kubuntu ein ProFTP installiert hast. Das deinstallierst Du dann am besten und arbeitest nur noch mit Xampp.

P.S.: Du kannst selbstverständlich auch alles so lassen, wie es ist. Du startest einfach FTP aus der Xampp Installation nicht, das ist vollkommen wurscht. Man kann Apache und MariaDB einzeln starten (gib mal "sudo /opt/lampp/lampp help" im Terminal ein, da siehst Du, dass es tonnenweise Startoptionen gibt). Und dann benutzt Du den ProFTP von Kubuntu. Damit Apache und FTP harmonieren, musst Du dann einen User im System einrichten, dessen HOME Verzeichnis /opt/lampp/htdocs ist. Ich habe dafür einfach einen neuen User "xampp" angelegt in Linux und habe vor allem dann auch für /opt/lampp/htdocs die Benutzereigenschaften angepasst, das gehört jetzt dem User "xampp" und auch alle Unterdateien. Das geht beispielsweise mit "sudo chown -R xampp /opt/lampp/htdocs". Vergiss nur nicht, VORHER den User xampp im System anzulegen (mit "adduser" Befehl oder im Systemsetup Benutzer für Kubunutu). Und dann loggsr Du Dich im ftp client für den richtigen Host ein (wahrscheinlich "localhost") und gibst dort "xampp" als User an. Und damit auch Apache alles lesen und schreiben darf, änderst Du in httpd.conf das Setting des User ("User daemon" ist Default, daraus machst Du "User xampp") und startest Apache neu. Dann ist es perfekt. Und am besten ordnest Du für Deine eigenen UserID und für User xampp noch eine gemeinsame Group zu, damit Du auch mit Deiner persönlichen UserID im htdocs Verzeichnis schreiben darfst. Dafür musst Du ggf. auch noch mit "chmod" in htdocs die Dateirechte anpassen und beim o.g. chown Kommando gibst Du nicht nur den User xampp an, sondern auch die gewünschte Gruppe (einfach per Doppelpunkt dahinter schreiben: sudo chown -R xampp:gruppe /opt/lampp/htdocs). Für "gruppe" nimmst Du natürlich eine bestehende Gruppe, beispielsweise "users". Kannst aber auch dafür eine eigene Gruppe (auch einfach "xampp") anlegen und Deine UserId und die von Xampp zuordnen.

P.P.S.: Ich habe mir gerade mal die Default Konfiguration von ProFTP in Xampp angeschaut. Also eigentlich müßte das auch gehen, dann musst Du den Kubuntu ProFTP deinstallieren und benutzt den von Xampp. Wenn Du einen ftp client startest, musst Du Dich mit User "daemon" und Passwort "xampp" anmelden. Was hoffentlich geht.... wenn das alles nicht geht, kannst Du auch wie oben den Kubuntu FTP benutzen. Ich habe das aber mal blitzschnell ausprobiert, fluppt einwandfrei, einfach per ftp auf localhost mit daemon und xampp als Passwort anmelden, dann bist Du im Verzeichnis /opt/lampp/htdocs.
Nobbie
 
Posts: 11673
Joined: 09. March 2008 13:04

Re: proftp startet eim Systemstart immer automatisch

Postby alphaATquantum » 25. August 2020 22:29

Hallo lieber Helfer,

wie IpMan immer sagt DANKE das ich lernen durfte und DANKE für den Informationsaustausch!

Tatsächlich war ProFtpD bereits installiert!
Damit hatte ich leider nicht gerechnet da ich immer die minimal Installation von Kubuntu nehme aber es scheint wohl dabei zusein :(.
Deshalb wurde auch die config von /opt/lampp/etc/proftp.d ignoriert und deshalb gab es dann schon einen laufenden proftp Prozess nach Systemstart.

Habe es deinstalliert und bereinigt und alles läuft jetzt so wie ich es wollte, vielen Dank.

proftp deinstallieren inkl. aller dazugehörigen config Dateien und Pakete (die proftp Installation aus dem Apache Paket bleibt erhalten)
Für Ubuntu derivat:

Code: Select all
      sudo apt-get remove proftpd-basic --purge && sudo apt-get autoremove --purge


Vielen Dank für deine Mühe jetzt ist wieder alles sauber!

Gruss
alphaATquantum
alphaATquantum
 
Posts: 2
Joined: 24. August 2020 23:31
XAMPP version: 7
Operating System: Kubuntu 20.04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests