Unable to Install SQLSRV in MY MAC OS MOJAVE BY XAMPP

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Unable to Install SQLSRV in MY MAC OS MOJAVE BY XAMPP

Postby akarshn20 » 03. January 2021 16:27

Code: Select all
sudo /Applications/XAMPP/xamppfiles/bin/pecl install pdo_sqlsrv-5.8.1 sqlsrv-5.8.1

Warning: PHP Startup: Unable to load dynamic library 'php_pdo_sqlsrv_71_nts.so' (tried: /Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20170718/php_pdo_sqlsrv_71_nts.so (dlopen(/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20170718/php_pdo_sqlsrv_71_nts.so, 9): image not found), /Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20170718/php_pdo_sqlsrv_71_nts.so.so (dlopen(/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20170718/php_pdo_sqlsrv_71_nts.so.so, 9): image not found)) in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library 'php_sqlsrv_71_nts.so' (tried: /Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20170718/php_sqlsrv_71_nts.so (dlopen(/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20170718/php_sqlsrv_71_nts.so, 9): image not found), /Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20170718/php_sqlsrv_71_nts.so.so (dlopen(/Applications/XAMPP/xamppfiles/lib/php/extensions/no-debug-non-zts-20170718/php_sqlsrv_71_nts.so.so, 9): image not found)) in Unknown on line 0
downloading pdo_sqlsrv-5.8.1.tgz ...
Starting to download pdo_sqlsrv-5.8.1.tgz (181,286 bytes)
......................................done: 181,286 bytes
downloading sqlsrv-5.8.1.tgz ...
Starting to download sqlsrv-5.8.1.tgz (186,879 bytes)
...done: 186,879 bytes
35 source files, building
running: phpize
Configuring for:
PHP Api Version:         20170718
Zend Module Api No:      20170718
Zend Extension Api No:   320170718
Cannot find autoconf. Please check your autoconf installation and the
$PHP_AUTOCONF environment variable. Then, rerun this script.

ERROR: `phpize' failed


help me out on what i am doing wrong
akarshn20
 
Posts: 1
Joined: 03. January 2021 16:24
XAMPP version: 7.2.20
Operating System: Mac OS Mojave

Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 6 guests