Bitnami Wordpress Install error

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Bitnami Wordpress Install error

Postby tanderson92 » 29. December 2020 02:02

Currently using 8.0.0-2-vm on Mac 11.1.

I had a previously running version of XAMPP-VM that stopped after the upgrade to Big Sur. Instead of searching here, I first tried reinstalling, only I stupidly replaced my previous VM version with the non-VM version. This resulted in me losing my Wordpress installation. Not too worried because I have the database backed up.

I uninstalled the erroneous non-VM version and removed the ~/.bitnami folder just to be sure. Downloaded 8.0.0-2-vm and ran the installation. After install, I can start the stack, start all the services, mount the /opt/lampp directory, etc. I can open phpmyadmin at localhost:8080/phpmyadmin.

I followed the instructions at https://www.apachefriends.org/faq_stackman.html to re-install Wordpress. I downloaded the linux version which was named bitnami-wordpress-5.6-0-module-linux-x64-installer.run. I mounted /opt/lampp and copied that file into /opt/lampp/temp. Then I used the General tab to open a terminal and ran the following:
Code: Select all
cd /opt/lampp/temp
chmod +x bitnami-wordpress-5.6-0-module-linux-x64-installer.run
./bitnami-wordpress-5.6-0-module-linux-x64-installer.run

I mainly gave the default answer to all questions, chose a username and blog title, etc. Everything was fine until I hit Y to complete the installation. At the end, I see the following error:
Code: Select all
Warning: Problem running post-install step. Installation may not complete
correctly
 Error running /opt/lampp/bin/php -c "/opt/lampp/etc"
"/opt/lampp/apps/wordpress/scripts/setup.php": child process exited abnormally
Press [Enter] to continue:

At this point, I press enter, and it asks if I want to start the wordpress module. I select Y, but afterwards there is no wordpress instance running as far as I can tell. http://localhost:8080/wordpress auto changes to just localhost/wordpress and reports "connection refused." https://localhost:8443/wordpress (also enabled in the stack) reports "Error establishing a database connection."

If I run the installer again, it completes without error, but I still can't connect to the wordpress module.
Code: Select all
ps aux | grep word
shows no wordpress instance running, although I'm not sure if that's what it would call itself. I ran just a ps aux and didn't see anything that looked like wordpress, but I could have missed it.

I've tried completely deleting the XAMPP install including the ~/.bitnami folder, but after reinstallation the error persists. I think I'm missing something in the uninstall, because each time I reinstall XAMPP the IP address of the XAMPP stack increments by 1. Clearly there's some configuration out there that is left behind, and I'm not sure if that's throwing off the process.

Any ideas how to proceed from here?
tanderson92
 
Posts: 1
Joined: 29. December 2020 01:41
XAMPP version: 8.0.0-2-vm
Operating System: OS 11.1

Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 7 guests