When I run apache in xampp...

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

When I run apache in xampp...

Postby kenoli » 27. November 2020 02:25

When I run apache in xampp and go to localhost in a broswer or from my code writing software, I get a file not found error for every file I try to run.

The files are there.

Any idea what I am doing wrong?

I've used xampp for many years with no trouble and have it set up as I always set it up.

I have a symlink pointed at my directory from htdocs and the browser finds the file but instead of running it, I get a 404 file not found error.

Posts: 21
Joined: 11. May 2009 19:06

Re: When I run apache in xampp...

Postby Altrea » 27. November 2020 07:50

404 file not found means that the webserver cannot deliver the requested file because it cannot find it.
It can be the ressource you manually typed into your browser, or a misleading redirect, or something similar.

The first thing to check would be your Apache access.log to identify the request leading to this 404 response.
Because you did not provide any more information we are not able to assist you properly, sorry.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
AF Moderator
Posts: 10730
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: When I run apache in xampp...

Postby kenoli » 27. November 2020 19:17

Altrea -- Thanks for the reply. I discovered that in Big Sur, as opposed to Catalina, in order to run files in a subdirectory of the localhost root directory, I have to include the name of the localhost root directory. i.e.:


Where "Sites" is the local name of the localhost RootDirectory.

In Catalina and before, the name of the root directory was not require. i.e.:


with localhost pointing to the root directory.

I had to add "Sites" to the directory path in all my editor setup files for each site to get it to work.

I don't know if this is an xampp thing or a Big Sur thing. I would suspect it is actually xampp that made this change, though I didn't read about it on the website anywhere. Of course, Apple makes you work to discover how they change things, especially related to web servers. I still haven't gotten Apples installed version of php to work.

Posts: 21
Joined: 11. May 2009 19:06

Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 3 guests