XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby maxu_pl » 18. November 2020 07:48

xav999 wrote:
maxu_pl wrote:Hey guy's i've solution for our problem, how to get to our archiev from vm
1. You need to get old archive https://www.youtube.com/watch?v=4MJFQLEUVdY ( first 10 minutes off the movie )
2. You need to convert qcow2 to vmdk file https://www.virtualdennis.com/how-to-convert-qcow2-to-vmdk-for-vmware-using-macos/
3. Download and install new version of xampp ( if you would have error Error starting “XAMPP” stack: cannot calculate MAC address: signal killed ) You have to close xampp, then type on your terminal:
rm -rf ~/.bitnami/stackman
4. Use 7zip to open archiev vmdk path opt --> lampp -->htdocs
It took me 8 hours. I hope I helped you make it faster :)


Thanks for this solution because I have the same error (Error starting “XAMPP” stack: cannot calculate MAC address: signal killed ). Just a question before I start, did you recover also your database?

Nop
maxu_pl
 
Posts: 7
Joined: 17. November 2020 10:33
XAMPP version: 7.4.12-0
Operating System: MacOS

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby DennisV » 18. November 2020 09:12

No need to extract any thing.
Just delete the hyperkit, start the vm and the message about mac is gone, mount drive, recover files, and db.
DennisV
 
Posts: 7
Joined: 17. November 2020 14:49
XAMPP version: 7.4.12
Operating System: OSX Big Sur

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby xav999 » 18. November 2020 09:23

DennisV wrote:No need to extract any thing.
Just delete the hyperkit, start the vm and the message about mac is gone, mount drive, recover files, and db.

I guess that by "delete de hyperkit" you mean execute rm -rf ~/.bitnami/stackman
I did that, but I get a vanilla XAMPP VM install so I lost all my files and db tables
xav999
 
Posts: 7
Joined: 13. November 2020 16:19
XAMPP version: 7.4.2
Operating System: MacOS

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby xav999 » 18. November 2020 09:50

maxu_pl wrote:
xav999 wrote:
maxu_pl wrote:Hey guy's i've solution for our problem, how to get to our archiev from vm
1. You need to get old archive https://www.youtube.com/watch?v=4MJFQLEUVdY ( first 10 minutes off the movie )
2. You need to convert qcow2 to vmdk file https://www.virtualdennis.com/how-to-convert-qcow2-to-vmdk-for-vmware-using-macos/
3. Download and install new version of xampp ( if you would have error Error starting “XAMPP” stack: cannot calculate MAC address: signal killed ) You have to close xampp, then type on your terminal:
rm -rf ~/.bitnami/stackman
4. Use 7zip to open archiev vmdk path opt --> lampp -->htdocs
It took me 8 hours. I hope I helped you make it faster :)


Thanks for this solution because I have the same error (Error starting “XAMPP” stack: cannot calculate MAC address: signal killed ). Just a question before I start, did you recover also your database?

Nop

thanks. How did you find 7zip for Mac? I can't find it
xav999
 
Posts: 7
Joined: 13. November 2020 16:19
XAMPP version: 7.4.2
Operating System: MacOS

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby maxu_pl » 18. November 2020 10:35

SORRY I FORGET TO MENTION...FOR THIS PART I'VE USED WINDOWS :)
maxu_pl
 
Posts: 7
Joined: 17. November 2020 10:33
XAMPP version: 7.4.12-0
Operating System: MacOS

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby maxu_pl » 18. November 2020 10:40

DennisV wrote:
maxu_pl wrote:Hey guy's i've solution for our problem, how to get to our archiev from vm
1. You need to get old archive https://www.youtube.com/watch?v=4MJFQLEUVdY ( first 10 minutes off the movie )
2. You need to convert qcow2 to vmdk file https://www.virtualdennis.com/how-to-convert-qcow2-to-vmdk-for-vmware-using-macos/
3. Download and install new version of xampp ( if you would have error Error starting “XAMPP” stack: cannot calculate MAC address: signal killed ) You have to close xampp, then type on your terminal:
rm -rf ~/.bitnami/stackman
4. Use 7zip to open archiev vmdk path opt --> lampp -->htdocs
It took me 8 hours. I hope I helped you make it faster :)


What a crap, absolute B*LLSH*T.

No need to convert any archives etc.

Downloaded the new VM 7.4.12, took me 30 seconds, everything up and running again!

No need to convert or extract any thing, no need to start all over again. No need to bash Apple.

NICE THX FROM YOU ....REMEBER YOU'RE NOT THE ONLY ONE IN THIS WORLD...I DIDNT HAVE MY FILES IN VM SO THATS TE SOLUTION FOR PEOPLE WHO ARE AFRIAD OFF THIS SCENARIO .....
maxu_pl
 
Posts: 7
Joined: 17. November 2020 10:33
XAMPP version: 7.4.12-0
Operating System: MacOS

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby deemaazizn » 18. November 2020 13:04

rebelit wrote:Instructions to recover files from xampp-vm on mac

For anyone that is stuck since the Big Sur update and needs to recover files from xampp-vm the following worked for me. There’s probably an easier way to do it but it works.

To recover files you need to convert the xampp qcow2 virtual disk to VDI format. You then mount that VDI disk as an additional disk to a debian virtual machine in virtualbox. You then install the guest additions which allows you to share a folder between the mac host and guest debian OS. You can then copy your files to the shared folder on your mac.

Convert qcow2 disk to vdi

VM Location
/Users/{your user}/.bitnami/stackman/machines/xampp/vm/
qemu-img convert -O vdi machine.qcow2 machine.vdi

Qemu can be installed via brew
brew install qemu

Install a debian vm in virtual-box.
https://www.virtualbox.org/wiki/Downloads
https://www.debian.org/distrib/netinst

Install the default graphical version of debian

Install guest additions which will allow a shared folder between the host and vm
https://linuxize.com/post/how-to-install-virtualbox-guest-additions-on-debian-10/

Shutdown the VM and add the additional VDI disk manually in the VM settings

Add VDI as extra hard drive in settings
settings/storage/add disk/

Mount vdi as extra disk in the debian vm
https://serverfault.com/questions/315290/mount-second-hard-drive-debian

mkdir -p /new/drive/
mount /dev/sdb1 /new/drive (your disk may have a different label i.e sdb2)

Create shared folder
https://averagelinuxuser.com/virtualbox-shared-folder/

Copy files from mounted VDI to shared folder on your mac.
/opt/lampp/htdocs/ is the default directory for web files



thanks alot, I got this error after installing qemu and running the first command:

sudo: .bitnami/stackman/machines/xampp/vm/: command not found

Please any suggestions to solve that, I need to recover all the files, they are job-related.

Best regards,
deemaazizn
 
Posts: 2
Joined: 18. November 2020 12:54
XAMPP version: 7.4.7
Operating System: MacOS

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby Nobbie » 18. November 2020 16:38

maxu_pl wrote:Who is small fish and who is big shark in this ocean.....


Thats the problem, but anyway, Apple has to ensure that all programs have to work properly. What would you say, if not only Xampp, but also lets say Adobe Photoshop does not run any further, same for Lightroom, also your Video editor does not run etc. pp. - would you still agree, thats not an Apple problem, its the problem of all the "small fishes" out there?

I would not. I would leave Apple alone, why should i spend money for the "big shark", which does not care for my expensive programs which i previously bought for Apple computers and all of a sudden, these programs do not run anymore on my Apple computer? You have a very strange understanding and actually, you are wasting money. Fortunately, Xampp comes for free, but there is plenty of software which does not come free for MacOS - you would waste all your money because you agree to Apple, they dont need to care for "small fishes"? Wow.

At least one more reason to go for Linux.
Nobbie
 
Posts: 11918
Joined: 09. March 2008 13:04

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby rebelit » 18. November 2020 23:04

deemaazizn wrote:
rebelit wrote:Instructions to recover files from xampp-vm on mac

For anyone that is stuck since the Big Sur update and needs to recover files from xampp-vm the following worked for me. There’s probably an easier way to do it but it works.

To recover files you need to convert the xampp qcow2 virtual disk to VDI format. You then mount that VDI disk as an additional disk to a debian virtual machine in virtualbox. You then install the guest additions which allows you to share a folder between the mac host and guest debian OS. You can then copy your files to the shared folder on your mac.

Convert qcow2 disk to vdi

VM Location
/Users/{your user}/.bitnami/stackman/machines/xampp/vm/
qemu-img convert -O vdi machine.qcow2 machine.vdi

Qemu can be installed via brew
brew install qemu

Install a debian vm in virtual-box.
https://www.virtualbox.org/wiki/Downloads
https://www.debian.org/distrib/netinst

Install the default graphical version of debian

Install guest additions which will allow a shared folder between the host and vm
https://linuxize.com/post/how-to-install-virtualbox-guest-additions-on-debian-10/

Shutdown the VM and add the additional VDI disk manually in the VM settings

Add VDI as extra hard drive in settings
settings/storage/add disk/

Mount vdi as extra disk in the debian vm
https://serverfault.com/questions/315290/mount-second-hard-drive-debian

mkdir -p /new/drive/
mount /dev/sdb1 /new/drive (your disk may have a different label i.e sdb2)

Create shared folder
https://averagelinuxuser.com/virtualbox-shared-folder/

Copy files from mounted VDI to shared folder on your mac.
/opt/lampp/htdocs/ is the default directory for web files



thanks alot, I got this error after installing qemu and running the first command:

sudo: .bitnami/stackman/machines/xampp/vm/: command not found

Please any suggestions to solve that, I need to recover all the files, they are job-related.

Best regards,



You need to navigate in the mac terminal to the directory where the xampp-vm virtual machine is stored before running the qemu convert command.
Open the mac terminal and enter this command and press enter:

cd ~/.bitnami/stackman/machines/xampp/vm/

then run the convert command below:

qemu-img convert -O vdi machine.qcow2 machine.vdi

then continue with the other steps above.
rebelit
 
Posts: 2
Joined: 14. November 2020 09:25
XAMPP version: xampp-vm
Operating System: mac

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby DennisV » 19. November 2020 08:44

xav999 wrote:
DennisV wrote:No need to extract any thing.
Just delete the hyperkit, start the vm and the message about mac is gone, mount drive, recover files, and db.

I guess that by "delete de hyperkit" you mean execute rm -rf ~/.bitnami/stackman
I did that, but I get a vanilla XAMPP VM install so I lost all my files and db tables


No by deleting the hyperkit i mean:

cd ~/.bitnami/stackman/helpers
look for a file named "hyperkit", delete it!

Start you VM and all is well.

DON'T DELETE THE WHOLE STACKMANN FOLDER, JUST THE HYPERKIT FILE!
DennisV
 
Posts: 7
Joined: 17. November 2020 14:49
XAMPP version: 7.4.12
Operating System: OSX Big Sur

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby maxu_pl » 19. November 2020 11:23

Nobbie wrote:
maxu_pl wrote:Who is small fish and who is big shark in this ocean.....


Thats the problem, but anyway, Apple has to ensure that all programs have to work properly. What would you say, if not only Xampp, but also lets say Adobe Photoshop does not run any further, same for Lightroom, also your Video editor does not run etc. pp. - would you still agree, thats not an Apple problem, its the problem of all the "small fishes" out there?

I would not. I would leave Apple alone, why should i spend money for the "big shark", which does not care for my expensive programs which i previously bought for Apple computers and all of a sudden, these programs do not run anymore on my Apple computer? You have a very strange understanding and actually, you are wasting money. Fortunately, Xampp comes for free, but there is plenty of software which does not come free for MacOS - you would waste all your money because you agree to Apple, they dont need to care for "small fishes"? Wow.

At least one more reason to go for Linux.

Now with new M1 chip you've similar problem. Photoshop need emulator to work. So Apple create Rozeta but in the end Adobe need to work on compatible version.
maxu_pl
 
Posts: 7
Joined: 17. November 2020 10:33
XAMPP version: 7.4.12-0
Operating System: MacOS

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby Nobbie » 19. November 2020 12:51

maxu_pl wrote:Now with new M1 chip you've similar problem.


Not me. I am running Linux Mint. And instead of Photoshop i use GIMP, thats OK for me.
Nobbie
 
Posts: 11918
Joined: 09. March 2008 13:04

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby deemaazizn » 19. November 2020 13:34

DennisV wrote:
xav999 wrote:
DennisV wrote:No need to extract any thing.
Just delete the hyperkit, start the vm and the message about mac is gone, mount drive, recover files, and db.

I guess that by "delete de hyperkit" you mean execute rm -rf ~/.bitnami/stackman
I did that, but I get a vanilla XAMPP VM install so I lost all my files and db tables


No by deleting the hyperkit i mean:

cd ~/.bitnami/stackman/helpers
look for a file named "hyperkit", delete it!

Start you VM and all is well.

DON'T DELETE THE WHOLE STACKMANN FOLDER, JUST THE HYPERKIT FILE!


You Are A GENIUS MAN I delete HYPERKIT and viola I retrieved all my files THANNNNNKKKKSSSS You saved me months of work.
deemaazizn
 
Posts: 2
Joined: 18. November 2020 12:54
XAMPP version: 7.4.7
Operating System: MacOS

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby xav999 » 19. November 2020 14:03

DennisV wrote:
xav999 wrote:
DennisV wrote:No need to extract any thing.
Just delete the hyperkit, start the vm and the message about mac is gone, mount drive, recover files, and db.

I guess that by "delete de hyperkit" you mean execute rm -rf ~/.bitnami/stackman
I did that, but I get a vanilla XAMPP VM install so I lost all my files and db tables


No by deleting the hyperkit i mean:

cd ~/.bitnami/stackman/helpers
look for a file named "hyperkit", delete it!

Start you VM and all is well.

DON'T DELETE THE WHOLE STACKMANN FOLDER, JUST THE HYPERKIT FILE!


"You Are A GENIUS MAN I delete HYPERKIT and viola I retrieved all my files THANNNNNKKKKSSSS You saved me months of work."

You are lucky. It almost worked for me (I had deleted the whole folder so I deleted again everything, and copied back only the backup of my vm), but now xampp works except for mounting the volume... I get a beautiful error. And th IP adress has changed fromm 192.168.64.2 to 192.168.64.3 and now 192.168.64.4
It's a nightmare
xav999
 
Posts: 7
Joined: 13. November 2020 16:19
XAMPP version: 7.4.2
Operating System: MacOS

Re: XAMPP 7.4.7 NOT WORKS ON MAC OS BIG SUR

Postby atticusat » 20. November 2020 12:46

So after trying a few of the things suggested here (deleting hyperkit, but got the mount error), I've found a simple solution that works for me. I hope it helps others too.

1. Rename your .bitnami folder in your *user* directory to .bitnami_old
2. Rename your XAMPP application in your application folder to XAMPP_old
3. Install the latest version of XAMPP: xampp-osx-7.4.12-0-vm (https://www.apachefriends.org/xampp-files/7.4.12/xampp-osx-7.4.12-0-vm.dmg)
4. Quit XAMPP if it automatically opened
4. Copy all of the contents of .bitnami_old to the newly generated .bitnami folder.
5. Delete the hyperkit file found in .bitnami > stackman > helpers.
6. Start the new XAMPP, start and mount should work and your files should all be restored.
(7.) Make sure you backup your databases and htdocs before the next major MacOS release!

Hope this helps someone!
atticusat
 
Posts: 3
Joined: 20. November 2020 12:37
XAMPP version: 7.4.12
Operating System: MacOS Big Sur

PreviousNext

Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 6 guests