Can't start ProFTPD and Apache services - files missing

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Can't start ProFTPD and Apache services - files missing

Postby thomasdesign » 10. October 2019 14:55

When I try to start all services in the XAMPP Mac client, MySQL starts but not ProFTPD and Apache. I get these error messages in the log:

Code: Select all
ERROR: Failed to start "proftpd": cannot start service: debian proftpd[551]: Fatal: unable to read configuration file '/opt/lampp/etc/proftpd.conf': No such file or directory

ERROR: Failed to start "apache": cannot start service: httpd: Could not open configuration file /opt/lampp/etc/httpd.conf: No such file or directory


If I check in the /etc/ folder, the files proftpd.conf and httpd.conf as well as other files that might be there are missing and all the subfolders have empty files.

In my /htdocs/ folder, all my folders there for WordPress installations seems to be missing files in their root folder (such as .htaccess, wp-config.php, different essential WP install files). The same goes for the /wp-admin/, /wp-includes/ and /wp-content/-folders where most of the files seems to be missing, even uploaded images. I can't find these files in the trash because I have unfortunately emptied my trash before I noticed this issue.

I tried to copy the remaining files from one of the subfolders in /htdocs/, but then I get a message about not enough permission:

Code: Select all
Items can’t be copied to [my destination folder] because you don’t have permission to read them.


I don't remember doing anything special that might have caused this. I use FileZilla for transfering files and VPN services from time to time.

Things I have tried:
- Restart and shut down computer
- Restart XAMPP Services, mount volume, start network in different orders
- Show/hide hidden files in lampp folder
- Starting XAMPP services with and without VPN running
- Starting services with localhost port set to 81

The most important thing for me now is to access one of my databases, that's what's keeping me from doing a full re-install of XAMPP.
If I look up the folder now in /lampp/var/mysql/, it's 0 bytes and I don't have permission to open it.

Is there a way for me to get back permissions and recover my database?
thomasdesign
 
Posts: 1
Joined: 10. October 2019 14:34
XAMPP version: 7.3.5-1
Operating System: Mac OS Mojave 10.14.3

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests