Apache won't run - config test fails - Segmentation failure

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Apache won't run - config test fails - Segmentation failure

Postby XAMPgoodrich » 17. January 2019 00:30

Hi all, new to web development here.
Downloaded and installed XAMPP 7.3.0. Tried to run Apache and it generated the following error in the Server Events tab:

Image

Starting Apache Web Server...
Exit code: 8
Stdout:
apache config test fails, aborting
Stderr:
/Applications/XAMPP/xamppfiles/apache2/scripts/ctl.sh: line 49: 28433 Segmentation fault $HTTPD -t

Please note this is the same error I received with XAMPP 7.3.0 but after hearing it may be an issue with it trying to load both older (php5) and newer (php7) PHP I downloaded and installed XAMPP 5.6.39-0 and got the same error as you can see in the picture.

I tried commenting out the load_module php5 line in the httpd.conf file but that didn't work.

A similar problem was asked twice before on this forum but never answered.
Any suggestions?

Thanks in advance.
XAMPP ver. 5.6.39-0 and 7.3.0
Mac OS 10.6.8 Snow Leopard
XAMPgoodrich
 
Posts: 1
Joined: 17. January 2019 00:08
XAMPP version: 5.6.39-0
Operating System: 10.6.8

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests