OS xampp vm - error 403 - Even though all config are correct

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

OS xampp vm - error 403 - Even though all config are correct

Postby xmetienne » 22. March 2018 10:36

Hi there,

For web development training and php learning purposes, I have just installed OS xampp vm on my MacBook Pro, I have cross check the system and hardware requirement and I am OK on that side, it has the right processor architecture and other features necessary to run xampp-vm. All seems to be OK however I am getting an issue accessing phppmyadmin, as I am constantly getting a error 403. I have managed to access it the first time when I did the setup by now it is impossible. Here are the steps I have already taken until now:

Improved security with
Code: Select all
/opt/lampp/lampp security
but chose to leave mysql accessible via the network
Set and change initial passwords for phpmyadmin, as 127.0.0.1, localhost and pm.
Same for ProFTP
Changed the permissions of config.inc.php to 777, as I could not access it, to then add the root password
Activated the eAccelerator by the changed on the php.ini file
Activated the OCI8 Oracle extension
Changed the httpd-xampp.conf to:
Alias /phpmyadmin "/opt/lampp/phpmyadmin/"
Code: Select all
<Directory "/opt/lampp/phpMyAdmin">
AllowOverride AuthConfig
Require all granted

Changed the http.conf to:
Code: Select all
<Directory "/opt/lampp/apache2/htdocs">
Options Indexes FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>


When trying to access phpmyadmin with or from:
localhost dashboard link
http://localhost:8080/phpmyadmin
http://127.0.0.1:8080/phpmyadmin
http://xxx.xxx.xx.x:8080/phpmyadmin

I am always getting the following:
Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.
If you think this is a server error, please contact the webmaster.
Error 403
xxx.xxx.xx.x
Apache/2.4.29 (Unix) OpenSSL/1.0.2n PHP/7.2.3 mod_perl/2.0.8-dev Perl/v5.16.3


I have changed the permissions from the root folder to 777 restarted it, but same issue...

Well, have tried to find further information on this forum or on internet, but I am always getting the httpd-xampp.conf modification solution and it does not work...

That's it I have reached to the limit of meager knowledge and really stuck... a solution would be highly appreciated...

Thanks...
User avatar
xmetienne
 
Posts: 1
Joined: 21. March 2018 10:31
Location: Switzerland, East Africa, Tanzania, Zanzibar
XAMPP version: 7.2.3
Operating System: OSX XAMPP-VM

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests