Unable to install Laravel On XAMPP-VM

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Unable to install Laravel On XAMPP-VM

Postby ahsanzameer » 21. January 2018 14:29

Hi,

I have successfully installed xampp-vm and composer on Mac OS X Sierra. Now I am trying to install laravel using composer. But when I hit composer global require laravel/laravel it shows me list of errors:

laravel/laravel
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don't install laravel/laravel v5.5.28
- Conclusion: don't install laravel/laravel v5.5.22
- Conclusion: remove symfony/console v4.0.3
- Installation request for laravel/laravel ^5.5 -> satisfiable by laravel/laravel[v5.5.0, v5.5.22, v5.5.28].
- Conclusion: don't install symfony/console v4.0.3
- laravel/laravel v5.5.0 requires laravel/framework 5.5.* -> satisfiable by laravel/framework[v5.5.0, v5.5.1, v5.5.10, v5.5.11, v5.5.12, v5.5.13, v5.5.14, v5.5.15, v5.5.16, v5.5.17, v5.5.18, v5.5.19, v5.5.2, v5.5.20, v5.5.21, v5.5.22, v5.5.23, v5.5.24, v5.5.25, v5.5.26, v5.5.27, v5.5.28, v5.5.29, v5.5.3, v5.5.30, v5.5.31, v5.5.32, v5.5.4, v5.5.5, v5.5.6, v5.5.7, v5.5.8, v5.5.9].

error messages continue

I don't know how to tackle this issue. At first I though it is a PHP version issue. But XAMPP-VM is already using PHP 7.1.1 version. Please help me.
Thanks
ahsanzameer
 
Posts: 1
Joined: 21. January 2018 14:02
XAMPP version: VM
Operating System: Mac OS X

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests