XAMPP UI not working after adding mongodb.so to php.ini

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMPP UI not working after adding mongodb.so to php.ini

Postby n.r. » 19. October 2017 09:39

Hey

I installed the current XAMPP 7.1.9 and used homebrew to install the latest mongodb-driver.

Usually I would use the XAMPP UI to restart the apache. But after I add

Code: Select all
extension="/usr/local/opt/php71-mongodb/mongodb.so"


to the php.ini file I am not able to use the UI anymore, even if I remove the line.

I figured out, that some rights changed. Starting the apache from the console with

/Applications/XAMPP/xamppfiles/bin/httpd -k start -E /Applications/XAMPP/xamppfiles/logs/error_log -DSSL -DPHP


gives me the info, that the error.log is not writable. Thats easy to fix. No I can check the logs and I see this:

Code: Select all
(13)Permission denied: AH00072: make_sock: could not bind to address [::]:80
(13)Permission denied: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs


Also, thats not a problem. Running the Apache from CLI with sudo will do the trick.

But what I am wondering, and thats my question here:

I tracked all this down to this little event of adding the mongodb-Extension to the php.ini. After this, some rights are gone.Why is that and whats going wrong?

Thanks for your help
n.r.
 
Posts: 1
Joined: 19. October 2017 08:59
XAMPP version: 7.1.9
Operating System: OS X Sierra 10.12.6

Re: XAMPP UI not working after adding mongodb.so to php.ini

Postby Beltran » 24. October 2017 08:50

What you mean with "some rights are gone"? The approach looks correct, you need sudo for restarting apache and use the 80 port.
User avatar
Beltran
Power-User
 
Posts: 138
Joined: 22. March 2013 12:29
Operating System: Windows, Linux, OS X


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 6 guests