hyperkit: [ERROR]

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

hyperkit: [ERROR]

Postby roy.naquin » 02. October 2017 19:31

Hello,

My Mac Book crashed while XAMPP-VM was running.
After rebooting, I got the following message while trying to start XAMPP :
failed to start machine: hyperkit: [ERROR] Found a reference to cluster 23246 outside the file (max cluster 23124) from cluster 4.1970
hyperkit: [ERROR] Mirage block device raised exception: Qcow.Make(Base)(Time).Reference_outside_file(_, _)
Mirage-block error: Block device is disconnected
Could not open mirage-block device: Invalid argument
Could not open backing file: Invalid argument

I have already tried to remove the application and reinstall and read two forum questions here and can't figure out how to remove the bitnami folder or even if I have it. Are there instructions on how to do this? If these things don't work how can I access my localhost:8080 to retrieve files that I had stored in the htdocs folder?

https://community.apachefriends.org/vie ... 11465b36c6


Configuration :
MAcOs Sierra
XAMPP-VM / PHP 7.1.9

[EDIT by Altrea: moved to the english section of this board]
roy.naquin
 
Posts: 3
Joined: 02. October 2017 17:35
XAMPP version: XAMPP-VM / PHP 7.1.9
Operating System: Mac Sierra 10.12.6

Re: hyperkit: [ERROR]

Postby roy.naquin » 02. October 2017 20:49

Ok, i was able to get back in, but now i'm at IP Address: 192.168.64.3 how do I get to localhost:8080 where my wordpress and documents are stored?
roy.naquin
 
Posts: 3
Joined: 02. October 2017 17:35
XAMPP version: XAMPP-VM / PHP 7.1.9
Operating System: Mac Sierra 10.12.6

Re: hyperkit: [ERROR]

Postby Nobbie » 03. October 2017 10:56

Try 192.168.64.3:8080

Keep in mind, that XAMPP-VM cannot access to physical folder /Applications/Xampp/..../htdocs etc., as it is running in a virtual environment. If you need to access to your physical local file system (as /Applications/Xampp/....), you MUST NOT use XAMPP-VM, instead install one of the normal XAMPP installations (see https://www.apachefriends.org/de/download.html), which installs into /Applications/Xampp/....

XAMPP-VM installs into your local HOME folder into a hidden folder .bitnami
Nobbie
 
Posts: 9817
Joined: 09. March 2008 13:04

Re: hyperkit: [ERROR]

Postby roy.naquin » 08. October 2017 17:47

Thanks for the reply. I've since reinstalled XAMPP and had to start building my files over. This won't happen again because I'm using bitbucket to store files each night now :).
roy.naquin
 
Posts: 3
Joined: 02. October 2017 17:35
XAMPP version: XAMPP-VM / PHP 7.1.9
Operating System: Mac Sierra 10.12.6

Re: hyperkit: [ERROR]

Postby Beltran » 24. October 2017 07:38

Hi,

You can use the Network tab in the XAMPP UI to add a tunnel to your local host. The default one is configured as "localhost:8080 -> 80", that way you can access the app at localhost:8080 that is running in the linux virtualized at port 80. Could you check that tunnel is enabled?
User avatar
Beltran
Power-User
 
Posts: 143
Joined: 22. March 2013 12:29
Operating System: Windows, Linux, OS X


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests