XAMPP Getting Error when trying to start it

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMPP Getting Error when trying to start it

Postby jcsnyder » 09. September 2017 16:28

Hello, I'm running macOS 10.12.6 on an iMac 2017 and I'm getting this error whenever I try to start the XAMPP 1.7.8

cannot calculate MAC address: signal: killed


Any help on this matter would be great!

Also as a side note I have run

Code: Select all
sysctl kern.hv_support


and the output was:

Code: Select all
kern.hv_support: 1
jcsnyder
 
Posts: 3
Joined: 09. September 2017 16:22
XAMPP version: 7.1.8
Operating System: macOS 10.12.6

Re: XAMPP Getting Error when trying to start it

Postby juanjo » 12. September 2017 11:44

Hi, I apologize for the delay getting back to you. We believe it is related to some changes introduced in 10.12, we will provide you with a new version later today.

Thanks for reporting it!
juanjo
 
Posts: 4
Joined: 12. September 2017 11:41
XAMPP version: 7
Operating System: osx

Re: XAMPP Getting Error when trying to start it

Postby juanjo » 12. September 2017 14:29

Hi, we have posted a new build hopefully fixing the issue here:

viewtopic.php?f=29&t=75911&p=258152#p258152

I'm also adding it here for your convenience:

https://www.apachefriends.org/xampp-fil ... view-2.dmg

You will probably need to delete ~/.bitnami/stackman/helpers/hyperkit to make the new bundle properly update the malformed file.

Did it fix your issue?
juanjo
 
Posts: 4
Joined: 12. September 2017 11:41
XAMPP version: 7
Operating System: osx

Re: XAMPP Getting Error when trying to start it

Postby jcsnyder » 13. September 2017 14:50

Yes it did!

Thanks!
jcsnyder
 
Posts: 3
Joined: 09. September 2017 16:22
XAMPP version: 7.1.8
Operating System: macOS 10.12.6

Re: XAMPP Getting Error when trying to start it

Postby hafiz85sg » 20. September 2017 06:12

How do you delete ~/.bitnami/stackman/helpers/hyperkit on Mac?

Please advise, I can't find the folder.
hafiz85sg
 
Posts: 2
Joined: 20. August 2017 17:23
XAMPP version: -
Operating System: OSX 10.9.5

Re: XAMPP Getting Error when trying to start it

Postby jcsnyder » 20. September 2017 12:57

While in finder, go to
Go
at the top, and click on
Go to Folder
and type in

Code: Select all
~/.bitnami/stackman/helpers/hyperkit


And it should reveal the hidden folders!
jcsnyder
 
Posts: 3
Joined: 09. September 2017 16:22
XAMPP version: 7.1.8
Operating System: macOS 10.12.6

Re: XAMPP Getting Error when trying to start it

Postby HokuApps » 21. September 2017 07:07

select "show debug then restart and try to open your XAMPP control panel again, and then start your Apache.After that, XAMPP ran Apache without any problems.
HokuApps
 
Posts: 10
Joined: 11. September 2017 07:23
XAMPP version: 1.8.0
Operating System: Windows

Re: XAMPP Getting Error when trying to start it

Postby Nobbie » 21. September 2017 09:43

I dont know "finder" in OSX (i dont have a Mac), but i know lots about linux and file explorers, which mostly are very close to each other. In linux i simply can press the keys "ctrl.+h", that toggles the view between "show / dont show" hidden files. Its worth a try. Maybe apple key instead of ctrl. key.
Nobbie
 
Posts: 9628
Joined: 09. March 2008 13:04


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest