Apache Web Server Stopped

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Apache Web Server Stopped

Postby chrislstuckey » 30. November 2016 22:04

I'm having trouble running the Apache Web Server.

Just downloaded the XAMPP version 7.0.13 / PHP 7.0.13 to my mac (running OS X Yosemite).

In the XAMPP Manager
Under the tab "Manage Servers"
Server Status
MySQL Database Running
ProFTD Running
Apache Web Server Stopped

I have followed directions found on youtube and elswhere to update the Port #. I did this process manually with httpd.conf file, for the Port and httpd-ssl.conf local host. Then, restarted the manager-osx.

In my Web Browser
When I type 'localhost' in the web browser, the screen returns "It works!"
When I type "locahhost/phpmyadmin" in the web browser, the page returns "Not Found. The requested URL /phpmyadmin was not found on this server."

In the XAMPP Manager
I'm returning the same result. 1. highlight Apache 2. Click Start, 3. Server status momentarily "starting..." for 4 seconds, 4. Stopped

Alternatively, in the terminal (command line), when I type "sudo opt/lampp/lampp start" input password, the result is 'sudo: opt/lampp/lampp: command not found'

If you have any suggestions how to resolve this error, please let me know your thoughts.
chrislstuckey
 
Posts: 1
Joined: 30. November 2016 21:27
XAMPP version: 7.0.13
Operating System: OS X Yosemite

Re: Apache Web Server Stopped

Postby Nobbie » 01. December 2016 14:30

chrislstuckey wrote:I have followed directions found on youtube and elswhere to update the Port #.


That is a very bad directive and you should not follow it. It makes things even worse. Instead you should find out, why Port 80 is blocked and which process is responsible for that.

chrislstuckey wrote:When I type 'localhost' in the web browser, the screen returns "It works!"


And this clearly says, that there is already another(!) Apache installed, up and running! And of course that is the reason, why Xampps Apache cannot use Port 80, as your other Apache already uses Port 80. But this other Apache is installed somewhere else and configured differently, that is the reason why you cannot find PhpMyAdmin, its not installed in that Apache environment.

Because you changed the Port of Xampps Apache from 80 to somewhat (you did not tell us which Port you choose), you have to enter the Port number as well in the URL in order to access Xampps Apache:

http://localhost:XXXX where XXXX is the Port number (for example http://localhost:8080 - and the same for phpmyadmin, enter http://localhost:8080/phpmyadmin or similar).

This is also the reason, why the Xampp Manager does not work well, it does not know that Apache is NOT running on Port 80.

chrislstuckey wrote:Alternatively, in the terminal (command line), when I type "sudo opt/lampp/lampp start" input password, the result is 'sudo: opt/lampp/lampp: command not found'


This is "twice" faulty:

1) you are missing a slash in the beginning of the path, it must be "sudo /opt/lampp/lampp start"

2) it is totally wrong anyway, as this is taken from the Linux(!!!) Version, but you are running a Mac OSX.
Nobbie
 
Posts: 9562
Joined: 09. March 2008 13:04


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests