PROFTPD 530 login incorrect

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

PROFTPD 530 login incorrect

Postby gegeMartinelli » 07. November 2016 11:48

Hello everybody,

I have installed the last version of XAMPP on my MAc OS X (Sierra). I had no problem running Apache and MySQL servers, but it is not the case for PROFTPD.

The server starts correctly, but when I'm trying to access the server from another system (Filezilla client under Windows ) I always got a wrong login message (530 incorrect login).
Of course the identification and password are correct (my own user-id on my MAC).
I have tried changing many things on the original proftpd.conf file to make this works, but all tries failed.

Does anyone have a configuration file which works correctly that i can use as an example ? Thanks in advance.

I have another question (still related to login). Is it possible for users not defined on the MAc to logon on this FTP server ?
If so how to define this user in the configuration file, and what about the password ?

Thanks for any help, comment, or suggestion.

Gege
gegeMartinelli
 
Posts: 13
Joined: 23. May 2013 15:34
Operating System: Windows Vista

Re: PROFTPD 530 login incorrect

Postby Nobbie » 07. November 2016 12:03

gegeMartinelli wrote:Does anyone have a configuration file which works correctly that i can use as an example ?


Didnt you read the original ProFTPD documentation? It is well documented, including examples. Enter "proftpd manual" in Google and you will find plenty of good examples and documentation:

http://www.proftpd.org/docs/
http://www.proftpd.org/docs/example-conf.html

etc.pp.

You may also enter "man proftpd" in a terminal for a manual.

gegeMartinelli wrote:Is it possible for users not defined on the MAc to logon on this FTP server ?


Yes, ProFTPD knows so called "Virtual Users": http://www.proftpd.org/docs/howto/VirtualUsers.html
Nobbie
 
Posts: 9569
Joined: 09. March 2008 13:04

Re: PROFTPD 530 login incorrect

Postby gegeMartinelli » 08. November 2016 12:00

Thanks a lot for the answer.
In fact I had read most the information you pointed to me (not all items but many). As I said previously, I made a lot of tries with different directives, and none worked.
Here is my last config, (which does not work). Could you tell me what's wrong with it.

Code: Select all
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "daemon" and "ftp" for normal operation and anon.

ServerName         "ProFTPD"
ServerType         standalone
DefaultServer         on

# Port 21 is the standard FTP port.
Port            21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask            022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances         30

# Set the user and group that the server normally runs at.
User gerardmartinelli
Group     staff

# Normally, we want files to be overwriteable.
<Directory />
  AllowOverwrite      on
</Directory>

# only for the web servers content
DefaultRoot /Applications/XAMPP/xamppfiles/htdocs

 
# daemon gets the password "xampp"
UserPassword daemon 2TgxE8g184G9c

 
UseFtpUsers off



The server starts correctly, but I cannot logon. Instead of using Filezilla client to logon, to alllow you to see, I tried in DOS command mode under windows. Here is what I got

ftp 192.168.1.13
Connecté à 192.168.1.13.
220 ProFTPD 1.3.4c Server (ProFTP
Utilisateur (192.168.1.13:(none)) :
gerardmartinelli

331 Password required for gerardmartinelli
Mot de passe :
/* here I entered my MAC password */
530 Login incorrect.
Échec de l'identification.
ftp>


I also tried with UseFtpUsers on but same result.

Any idea of what it's wrong with my configuration ?

Many thanks again for trying help me.
Gégé
gegeMartinelli
 
Posts: 13
Joined: 23. May 2013 15:34
Operating System: Windows Vista

Re: PROFTPD 530 login incorrect

Postby Nobbie » 08. November 2016 12:42

I just checked my proftpd.conf (i use a linux system) from Xampp and it looks quite like yours. Everything works without any problems, i can login with my standard user.

Did you try to run an ftp client on the Xampp server itself? And try to login to localhost? Maybe there is a firewall problem or similar, first of all check, if you can connect from a terminal on your Xampp PC.

What slightly confuses me, your login trys to run with "(none)" as default, on my systems always the current user is taken, which i used for the login on the specific client (i checked with my own login and with the login of my wife). It never shows "(none)", instead it shows my or her username. I did not use a Windows PC (i can check that as well if needed), i used two different linux PCs.
Nobbie
 
Posts: 9569
Joined: 09. March 2008 13:04

Re: PROFTPD 530 login incorrect

Postby gegeMartinelli » 08. November 2016 15:15

Thanks again for your so fast answer.

As you suggested, I tried to connect directly on my Mac using a Terminal session to eliminate any Firewall effect. The result is exactly the same except that instead of "none" I get my userid as you and your wife had.

I guess that "none" indicates that my Id of the remote computer (Windows) is not known yet from the FTP server, so that I have to type it.

Thanks again for all. If you (or anyone else) have new ideas, please let me know;

Gégé
gegeMartinelli
 
Posts: 13
Joined: 23. May 2013 15:34
Operating System: Windows Vista

Re: PROFTPD 530 login incorrect

Postby Nobbie » 08. November 2016 16:45

Only two ideas left:

a) userid or password is wrong / mistyped?

b) the user you try has root access rights. ProFTPD does not login users with root rights. Try to use a standard user instead.
Nobbie
 
Posts: 9569
Joined: 09. March 2008 13:04

Re: PROFTPD 530 login incorrect

Postby gegeMartinelli » 09. November 2016 09:34

[quote="Nobbie"]Only two ideas left:

a) userid or password is wrong / mistyped? No it was OK

b) the user you try has root access rights. ProFTPD does not login users with root rights. Try to use a standard user instead. I'm going to try this. But is this indicated in the documentation somewhere ?

However, I have defined virtual users, and this time it worked correctly but I cannot still logon with my Mac id and password.

A lot of thanks again for your help and especially to tell me about virtual users

Have a nice day

Gégé
gegeMartinelli
 
Posts: 13
Joined: 23. May 2013 15:34
Operating System: Windows Vista

Re: PROFTPD 530 login incorrect

Postby Nobbie » 09. November 2016 12:31

gegeMartinelli wrote:But is this indicated in the documentation somewhere ?


Honestly - i do not know. Maybe i am simply wrong, i only remember, that i never succeeded to login as "root" via FTP. Therefore i thought, it is an ProFTPD issue, but of course it can also be a security feature of the Operating System. I never investigated much time to it, as i dont need it.

In my Xampp environment, i defined a "xampp" User in my Linux and assigned the htdocs folder as HOME. I also did a "chown xampp" on htdocs. I adapted httpd.conf and made "xampp" the User for execution of Apache. This makes it easier for me, as all files are stored from user "xampp" (either from FTP or from Apache/PHP). it is a "clean" Xampp environment now.
Nobbie
 
Posts: 9569
Joined: 09. March 2008 13:04

Re: PROFTPD 530 login incorrect

Postby gegeMartinelli » 09. November 2016 15:06

I just defined a new user on my MAC without the administration privileges. When trying to logon it fails. This means it was not only a problem with admin privileges.
I should be another reason, but I haven't found yet; I tried with UseFtpUsers On and OFF, without getting any difference.
gegeMartinelli
 
Posts: 13
Joined: 23. May 2013 15:34
Operating System: Windows Vista

Re: PROFTPD 530 login incorrect

Postby Nobbie » 09. November 2016 15:31

Maybe OSX uses another login than the linux style via /etc/passwd and /etc/shadow? Or maybe the passwords are crypted in a different manner as ProFTPD expects it?

I just found a very usefull article about ProFTPD and OSX - there is a hint which exactly says, what i assumed above, see http://www.unibia.com/unibianet/os-x/install-proftpd

ProFTPD will by default use PAM to get system account information. This first needs to be enabled in OS X, otherwise users will not be able to log in with ProFTPD. The built in OS X FTP server utilizes the "/private/etc/pam.d/ftpd" authentication module. While ProFTPD is looking for "/private/etc/pam.d/ftp". Using the terminal, we will make a copy of the OS X FTP PAM module for ProFTPD.

Code: Select all
cp /private/etc/pam.d/ftpd /private/etc/pam.d/ftp
Nobbie
 
Posts: 9569
Joined: 09. March 2008 13:04

Re: PROFTPD 530 login incorrect

Postby gegeMartinelli » 09. November 2016 18:05

I did what is suggested (Copy) and this does not change anything. Still 530 error login.
gegeMartinelli
 
Posts: 13
Joined: 23. May 2013 15:34
Operating System: Windows Vista

Re: PROFTPD 530 login incorrect

Postby Nobbie » 09. November 2016 18:41

Use Linux instead.

I dont like Apple / OSX anyway...

gegeMartinelli wrote:I did what is suggested (Copy)


This is only 50% of the suggestion - the other part is "activation of PAM" (i have no idea how and where to do so in OSX; but it is part of the solution): "This first needs to be enabled in OS X".
And only after activating PAM, you need to copy the Password file as mentioned.
Nobbie
 
Posts: 9569
Joined: 09. March 2008 13:04


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests