Virtual Host from UBS - Error 403

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Virtual Host from UBS - Error 403

Postby agnemedia » 21. December 2015 22:37

Any way to update or setup group, or fix permission to External USB - virtualHost?

Access forbidden!

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.
If you think this is a server error, please contact the
Error 403
development.local
Apache/2.4.17 (Unix) OpenSSL/1.0.1p PHP/5.6.14 mod_perl/2.0.8-dev Perl/v5.16.3

Thank you
agnemedia
 
Posts: 5
Joined: 21. December 2015 22:31
Operating System: Mac

Re: Virtual Host from UBS - Error 403

Postby Nobbie » 21. December 2015 23:04

agnemedia wrote:Any way to update or setup group, or fix permission to External USB - virtualHost?


If it is a question of insufficient rights for the USB Drive, you have to grant access already in the mount-command for that drive. See your linux manual for "mount".

Anyway, the reason may also be an insufficient configuration of your VirtualHost in your Apache configuration. You need to grant access to that VirtualHost (via "Allow From All" or "Require all granted", depending on your Apache version), or you have to apply an index document (index.php or index.html) or you must specify "Options Indexes", otherwise Apache may not scan that folder.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Virtual Host from UBS - Error 403

Postby agnemedia » 22. December 2015 00:44

I found this solution work well

I have solve the problem .

in file "httpd.conf",there has another default Directory configuation like follow:
<Directory />
AllowOverride none
Require all denied
</Directory>
you can delete this directory or change is as follow:

<Directory />
AllowOverride all
Require all granted
</Directory>

more info here: http://stackoverflow.com/questions/31287314/access-forbidden-xampp-in-mac-php
agnemedia
 
Posts: 5
Joined: 21. December 2015 22:31
Operating System: Mac

Re: Virtual Host from UBS - Error 403

Postby Nobbie » 22. December 2015 10:26

agnemedia wrote:I found this solution work well

I have solve the problem .

in file "httpd.conf",there has another default Directory configuation like follow:
<Directory />
AllowOverride none
Require all denied
</Directory>
you can delete this directory or change is as follow:

<Directory />
AllowOverride all
Require all granted
</Directory>

more info here: http://stackoverflow.com/questions/3128 ... in-mac-php


Thats a bad solution, as it makes your server unsafe. You should only apply these changes to the VirtualHost (i.e. the DocumentRoot of that VirtualHost) instead, as i suggested above.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests