Xampp error 500 prestashop installation

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Xampp error 500 prestashop installation

Postby xax8910 » 24. November 2015 23:34

Hello,

Hope you are doing fine :) I have a problem installing the last version of Prestashop in localhost in a Mac Book pro. I didn´t have any problem with Windows but now I´m totally stucked and don´t know why. I have installed Xampp, created the database with phpmyadmin and activate the control panel: http://oi68.tinypic.com/2h81vfc.jpg

Then I have downloaded the last version of Prestahop. I have copied the folder inside xampp´s folder htdocs. The route will be the following one: xampp/htdocs/prestashop/install. However, when I tried to install prestashop I´m getting this error: http://oi65.tinypic.com/33krvnp.jpg

I don´t think that there´s a problem with routes. I have tried to download other programmes in localhost in the same laptop and I´m getting the same error :? Any idea?

Thanks a lot for your help and support

Looking forward to heraing from you soon :D
xax8910
 
Posts: 4
Joined: 24. November 2015 23:03
Operating System: IOS

Re: Xampp error 500 prestashop installation

Postby Altrea » 25. November 2015 00:02

Hi,

Please take a look into your Apache error.log and php_error_log.
Error 500 cannot be debugged without any additional log information.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Xampp error 500 prestashop installation

Postby Nobbie » 25. November 2015 11:11

xax8910 wrote:The route will be the following one: xampp/htdocs/prestashop/install


That looks very strange, please provide the full(!) pathname to us. I do not have an OSX installation here, but as far as i remember, there is no xampp/htdocs folder in a standard Xampp environment. Instead there is something like xamppfiles/htdocs or similar.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Xampp error 500 prestashop installation

Postby xax8910 » 25. November 2015 16:43

Hi Altrea and Nobbie,
Thank you very much for your help 

@Altrea
I´m attaching you the error.log from Apache and php_error_log (they are from today, same error)
Error.log
[Wed Nov 25 08:23:56.038107 2015] [ssl:warn] [pid 535] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Nov 25 08:23:56.061909 2015] [ssl:warn] [pid 535] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 25 08:23:56.062941 2015] [suexec:notice] [pid 535] AH01232: suEXEC mechanism enabled (wrapper: /Applications/XAMPP/xamppfiles/bin/suexec)
[Wed Nov 25 08:23:57.002213 2015] [ssl:warn] [pid 536] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Nov 25 08:23:57.002359 2015] [ssl:warn] [pid 536] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 25 08:23:57.002681 2015] [lbmethod_heartbeat:notice] [pid 536] AH02282: No slotmem from mod_heartmonitor
[Wed Nov 25 08:23:57.002721 2015] [auth_digest:notice] [pid 536] AH01757: generating secret for digest authentication ...
[Wed Nov 25 08:23:57.290780 2015] [mpm_prefork:notice] [pid 536] AH00163: Apache/2.4.17 (Unix) OpenSSL/1.0.1p PHP/5.6.14 mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
[Wed Nov 25 08:23:57.290841 2015] [core:notice] [pid 536] AH00094: Command line: '/Applications/XAMPP/xamppfiles/bin/httpd -E /Applications/XAMPP/xamppfiles/logs/error_log -D SSL -D PHP'
[Wed Nov 25 08:25:39.817413 2015] [mpm_prefork:notice] [pid 536] AH00169: caught SIGTERM, shutting down
[Wed Nov 25 14:59:34.092408 2015] [ssl:warn] [pid 918] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Nov 25 14:59:34.097288 2015] [ssl:warn] [pid 918] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 25 14:59:34.098734 2015] [suexec:notice] [pid 918] AH01232: suEXEC mechanism enabled (wrapper: /Applications/XAMPP/xamppfiles/bin/suexec)
[Wed Nov 25 14:59:35.002280 2015] [ssl:warn] [pid 919] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Nov 25 14:59:35.002432 2015] [ssl:warn] [pid 919] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 25 14:59:35.002764 2015] [lbmethod_heartbeat:notice] [pid 919] AH02282: No slotmem from mod_heartmonitor
[Wed Nov 25 14:59:35.002804 2015] [auth_digest:notice] [pid 919] AH01757: generating secret for digest authentication ...
[Wed Nov 25 14:59:35.354587 2015] [mpm_prefork:notice] [pid 919] AH00163: Apache/2.4.17 (Unix) OpenSSL/1.0.1p PHP/5.6.14 mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
[Wed Nov 25 14:59:35.354671 2015] [core:notice] [pid 919] AH00094: Command line: '/Applications/XAMPP/xamppfiles/bin/httpd -E /Applications/XAMPP/xamppfiles/logs/error_log -D SSL -D PHP'
[Wed Nov 25 15:02:37.065700 2015] [mpm_prefork:notice] [pid 919] AH00169: caught SIGTERM, shutting down

Php_error_log
[25-Nov-2015 08:24:28 Europe/Berlin] PHP Fatal error: Class 'Tools' not found in /Applications/XAMPP/xamppfiles/htdocs/prestashop/classes/PrestaShopAutoload.php on line 168
[25-Nov-2015 08:24:34 Europe/Berlin] PHP Fatal error: Class 'Tools' not found in /Applications/XAMPP/xamppfiles/htdocs/prestashop/classes/PrestaShopAutoload.php on line 168
[25-Nov-2015 15:02:26 Europe/Berlin] PHP Fatal error: Class 'Tools' not found in /Applications/XAMPP/xamppfiles/htdocs/prestashop/classes/PrestaShopAutoload.php on line 168

@Nobbie
Maybe I´m wrong but htdocs is in both sides: xampp>htdocs and xampp/xamppfiles/htdos. I have recorded a video to check if the problem is here. Take a look but Prestashop folders is in both sides 

https://www.youtube.com/watch?v=4piCf15ZssY

Hope you could help :)

Thanks a lot
xax8910
 
Posts: 4
Joined: 24. November 2015 23:03
Operating System: IOS

Re: Xampp error 500 prestashop installation

Postby Nobbie » 25. November 2015 17:53

xax8910 wrote:Php_error_log
[25-Nov-2015 08:24:28 Europe/Berlin] PHP Fatal error: Class 'Tools' not found in /Applications/XAMPP/xamppfiles/htdocs/prestashop/classes/PrestaShopAutoload.php on line 168


Thats it!

Proceed to a Prestashop Forum and show that error message. There is something missing.

P.S.: The two different htdocs folders are looking very very suspicous. I think, you mixed up something and/or put some wrong information into an unpacker or installer. I still dont know the OSX version, but I dont think, that there is a xampp/htdocs folder in a "clean" Xampp Installation. In your video it looks, as if "htdocs" in "Xampp" is a symbolic link (an "Alias" on OSX)? I am pretty sure, that the error is a result of this strange configuration. Dont ask me about these folders - you must have created them.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Xampp error 500 prestashop installation

Postby xax8910 » 26. November 2015 16:12

Thanks a lot Nobbie,

I have already sent the requesto to the forum. Anyway, anyone could help me with this? Sometimes it takes weeks to get a responde from them :(

I have tried to download the xampp version for mac again and same folders in same place so I think that´s how it´s installed in IOS right now. Yeah, htdos is the same folder in both sides but i think one is a shortcut and the other ones is in xamppfiles.
xax8910
 
Posts: 4
Joined: 24. November 2015 23:03
Operating System: IOS

Re: Xampp error 500 prestashop installation

Postby Nobbie » 26. November 2015 19:49

xax8910 wrote:but i think one is a shortcut and the other ones is in xamppfiles.


Yes, that can be. But i dont know Prestashop and i dont know, what is going wrong there. Sorry, but this is not a Prestashop support forum.

Only to give you any support i can, i downloaded (german) Prestashop, copied the folder to htdocs/prestashop and finally entered http://localhost/prestashop/install in my browser - and it worked! I also stepped thru the installation procedure and created a dummy shop for electronics etc. - everything worked without any hassle.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Xampp error 500 prestashop installation

Postby xax8910 » 01. December 2015 11:04

Hi again Nobbie :)

Thanks a lot for your help. I solved the problem installing an old version of Prestashop, the one that I installed in the Windows Os: 1.6.1.1. I was trying to do it with the last versions: 1.6.1.3 and 1.6.1.2, but it seems that there´s a problem with them. They were released during last month. I don´t know if this is the reason :/ Here is the link for previous versions in case someone has the same problem with the same version of Prestashop:

https://www.prestashop.com/en/developers-versions

Thanks! :)
xax8910
 
Posts: 4
Joined: 24. November 2015 23:03
Operating System: IOS


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 6 guests