Xampp - apache not starting

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Xampp - apache not starting

Postby batti74 » 10. October 2015 14:05

I was trying to install xdebug restarted the apache server and did not start.
So i re-installed xamp but apache still not starting

although application log is saying:
Starting Apache Web Server...
/Applications/XAMPP/xamppfiles/apache2/scripts/ctl.sh : httpd started

i tried to re-enter the port in the apache config and port 80 says that its taken by another application
so i tried port 8080 but still the same.

any ideas?
Posts: 1
Joined: 10. October 2015 13:56
Operating System: osx 10.10.5

Re: Xampp - apache not starting

Postby Nobbie » 10. October 2015 14:17

Maybe its already started and you try to start it twice?
Posts: 8628
Joined: 09. March 2008 13:04

Re: Xampp - apache not starting

Postby aceace » 23. May 2016 04:19

What I did to fix the same problem on my MBP OSX

My XAMPP Apache would say it was starting then not start.
Figured out I had been playing around with the OSX built-in Apache before I installed XAMPP and it was still running. I stopped they OSX Apache using a Terminal command:

sudo apachectl stop

Then started XAMPP Apache using manager-osx XAMPP Apache now starts and stays running

(I know this is an old post, but I had this same issue last week, so thought I would put my 2 cents in to help someone in the future who is searching for this same problem.)
Posts: 3
Joined: 22. May 2016 19:21
XAMPP version: 7.0.5-0
Operating System: OSX 10.11.4 El Capitan

Re: Xampp - apache not starting

Postby kamatama41 » 23. May 2016 15:15

I encountered same problem on the environment.
- MaxOS X 10.10.5
- Xampp 7.0.6-0

As the result of having a look at the script file "/Applications/XAMPP/xamppfiles/apache2/scripts/ctl.sh", I guess the line 69 is a bug about dealing with a return code.. I think $RESULT is correct.
Code: Select all
 61     is_apache_running
 62     RUNNING=$?
 64     if [ $RUNNING -eq 1 ]; then
 65         echo "$0 $ARG: httpd (pid $HTTPD_PID) already running"
 66     else
 67         /Applications/XAMPP/xamppfiles/xampp startapache > /dev/null
 68     RESULT=$?
 69         if [ $RUNNING -eq 0 ]; then
 70             echo "$0 $ARG: httpd started"
 71         else
 72             echo "$0 $ARG: httpd could not be started"
 73             ERROR=3
 74         fi

And then when I tried to run the command "/Applications/XAMPP/xamppfiles/xampp startapache" directly, the result was following.
Code: Select all
% /Applications/XAMPP/xamppfiles/xampp stopapache
XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system.
% echo $?

And then when I tried by v7.0.5-0, apache started properly..!
Posts: 1
Joined: 23. May 2016 14:38
XAMPP version: 7.0.6
Operating System: MaxOS X 10.10.5

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests