Fatal error: require_once(): Failed opening required

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Fatal error: require_once(): Failed opening required

Postby ando » 08. October 2015 18:20

Mac OS version = 10.9.5
XAMPP version = 1.8.3-1

Installed and started XAMPP normally using console XAMPP "manager-osx". All status seems fine with MySQL Database and Apache Web Server both in Running status. I can also access htt[://localhost with XAMPP home page showing normal.

However, when I try to run my own module under "htdocs" directory by entering "http://localhost/abc/" (assume "abc" is the module name). The browser returns me the below error.

Fatal error: require_once(): Failed opening required './modules/system/system.install' (include_path='.:/Applications/XAMPP/xamppfiles/lib/php') in /Applications/XAMPP/xamppfiles/htdocs/abc/install.php on line 25

I am new to XAMPP and Drupal apps. Hope this is no stupid question. Apologies if it is... Thanks in advance.
ando
 
Posts: 2
Joined: 08. October 2015 18:03
Operating System: Mac OS 10.9.5

Re: Fatal error: require_once(): Failed opening required

Postby Nobbie » 08. October 2015 21:44

It is not a Xampp issue. Either the application (Drupal??) has an error, or it is not installed correctly. You should ask in the corresponding forum.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Fatal error: require_once(): Failed opening required

Postby ando » 09. October 2015 01:44

Okie~ Thank you Nobbie!
ando
 
Posts: 2
Joined: 08. October 2015 18:03
Operating System: Mac OS 10.9.5


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests