XAMP Mysql Problems with Google Drive + Datadir

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMP Mysql Problems with Google Drive + Datadir

Postby xcrap » 14. August 2015 03:30

I've bought a Macbook Pro yesterday and I'm making the switch for my localhost web development from Windows do Mac Os.
I've been using Wamp without any problems. I've setup Xampp in the macbook without any problems.
The think is I always sync my data between two PC's, office and home. I use Google Drive to do it. To be easier I always disable INNODB for data corruption with Google Drive and so on...

Now I'm trying to sync the WAMP at my work PC with XAMPP at my Macbook Pro with Google Drive.
Everything works except with the database. When I set the datadir = /Users/myself/Drive/mysql, the mysql starts but the manager-osx keeps displaying the red icon as not started. So I can't also stop the mysql service, only with sudo killall mysqld or with the process ID. The most strange thing is that mysql is actually running, it only is not syncronizing with manager-osx, I can access my databases and all....

If I change the datadir to the default /Applications/..../xampfiles/var/mysql/ then it works normally. I've tryed to change the folder ownership, permissions, etc etc etc without success.

This is my error log from mysql:
2015-08-14 02:22:12 17166 mysqld_safe Starting mysqld daemon with databases from /Users/cesarcouto/drive/mysql
2015-08-14 02:22:12 0 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
2015-08-14 02:22:12 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2015-08-14 02:22:12 0 [Note] /Applications/XAMPP/xamppfiles/sbin/mysqld (mysqld 5.6.25) starting as process 17486 ...
2015-08-14 02:22:12 17486 [Warning] Setting lower_case_table_names=2 because file system for /Users/cesarcouto/drive/mysql/ is case insensitive
2015-08-14 02:22:12 17486 [Note] Plugin 'FEDERATED' is disabled.
2015-08-14 02:22:12 17486 [Warning] The option innodb (skip-innodb) is deprecated and will be removed in a future release
2015-08-14 02:22:12 17486 [Note] Plugin 'InnoDB' is disabled.
Warning: World-writable config file './auto.cnf' is ignored
2015-08-14 02:22:12 17486 [Warning] World-writable config file './auto.cnf' has been removed.

2015-08-14 02:22:12 17486 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 45cce1ee-422b-11e5-bd00-0cad424285d4.
2015-08-14 02:22:12 17486 [Note] RSA private key file not found: /Users/cesarcouto/drive/mysql//private_key.pem. Some authentication plugins will not work.
2015-08-14 02:22:12 17486 [Note] RSA public key file not found: /Users/cesarcouto/drive/mysql//public_key.pem. Some authentication plugins will not work.
2015-08-14 02:22:12 17486 [Note] Server hostname (bind-address): '*'; port: 3306
2015-08-14 02:22:12 17486 [Note] IPv6 is available.
2015-08-14 02:22:12 17486 [Note] - '::' resolves to '::';
2015-08-14 02:22:12 17486 [Note] Server socket created on IP: '::'.
2015-08-14 02:22:12 17486 [Warning] Info table is not ready to be used. Table 'mysql.slave_master_info' cannot be opened.
2015-08-14 02:22:12 17486 [Warning] Info table is not ready to be used. Table 'mysql.slave_relay_log_info' cannot be opened.
2015-08-14 02:22:12 17486 [Note] Event Scheduler: Loaded 0 events
2015-08-14 02:22:12 17486 [Note] /Applications/XAMPP/xamppfiles/sbin/mysqld: ready for connections.
Version: '5.6.25' socket: '/Applications/XAMPP/xamppfiles/var/mysql/mysql.sock' port: 3306 Source distribution


If anyone have any idea....
If I change the datadir to the default the error log is exactly the same (different folders of course) but it syncs with manager-osX and in other folder dont really.
Also the Windows version of WAMP i'm running is 5.6.17 and in XAMPP it's the 5.6.25.


The same technique but using AMPPS worked perfectly. But I would prefer using XAMPP because it has less "junk" :)
Any help would be appreciated, it's my second day on a MAC so I'm not very comfortable...
xcrap
 
Posts: 1
Joined: 14. August 2015 03:17
Operating System: Yosemite 10.10.4

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 8 guests

cron