error_reporting "not working" well, it works... but...

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

error_reporting "not working" well, it works... but...

Postby ertox » 18. January 2015 17:54

Hi there!

i run a xampp 5.6.3 on a Mac 10.9.5 and edited the php.ini in /etc/ of the xampp directory.
No i try around to disable everything, because i get:

A PHP Error was encountered
Severity: Notice

The programm is running fine but i can't get it disabled.
I tried:
error_reporting=off
display_errors=off
as well as the E_ALL Notice, Alert etc. which is documented in the php.ini accordignly...

Restart of Server of course has been done every time
But still, no luck...
Anyone an idea what might be the problem?

Thanks
Ertox
ertox
 
Posts: 2
Joined: 18. January 2015 17:48
Operating System: Win7

Re: error_reporting "not working" well, it works... but...

Postby Nobbie » 18. January 2015 23:10

Either you overlooked php_startup_errors and/or you edited the wrong php.ini?
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: error_reporting "not working" well, it works... but...

Postby ertox » 19. January 2015 21:09

no, it seams that this is a bug, i can see other folks have problem too.
i installed 1 version older on this mac, and it worked fine. same config etc.

a workaround is to set error_reporting=(0); in the php syntax.
but i am too lazy to do this on 45 files :-)

thanks anwayway

chears
ertox
ertox
 
Posts: 2
Joined: 18. January 2015 17:48
Operating System: Win7

Re: error_reporting "not working" well, it works... but...

Postby Nobbie » 20. January 2015 11:42

ertox wrote:error_reporting=off


Due to the PHP Manual, "off" is not a valid value for error_reporting. An integer value is expected instead, try to use 0 instead. Or a combination of the predefined constants E_BLABLABLA.

I dont know if the value of display_errors is case-sensitive, i could not find any example with "display_errors=off" or "display_errors=on". All documentation only shows "display_errors=On" or "display_errors=Off". Finally there may be a .htaccess in your project folder which overrules the default settings of php.ini (you can find out this via phpinfo()). Or there may be a setup script which is included by all PHP scripts (I dont know which application you are testing), which explicitely changes the error reporting.

What kind of application are you running?
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests