Installer does not start

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Installer does not start

Postby xipasduarte » 20. November 2014 02:48

Hello,

I tried to run the installer for all the latest versions where it became the default mode for installing XAMPP, 1.8.x and now 5.5.x and 5.6.x. However I could never get it to run. I mount the .dmg file and then double click the installer, it flashes a light indicator on the dock, but no app is ran.
As it turns out I managed to run the installer by moving it to a folder (ex. ~/Downloads) and then running the following script inside the installer's contents:
Code: Select all
sudo ~/Downloads/XAMPP.app/Contents/MacOS/osx-intel


The installer came to live and I was able to get the latest XAMPP. I post this not to get help for myself but so someone else might get a quick fix, and to shine a light on the issue.

Regards
OS: 10.7
XAMPP: 1.8.x and later
Last edited by xipasduarte on 20. November 2014 13:31, edited 1 time in total.
xipasduarte
 
Posts: 3
Joined: 20. November 2014 02:41
Operating System: OS 10.7 Lion

Re: Installer does not start

Postby xipasduarte » 20. November 2014 13:29

Well it seems that the uninstaller.app needs the same procedure to run on my setup.
Code: Select all
sudo /Applications/XAMPP/uninstall.app/Contents/MacOS/osx-intel

I still think this is only related to the XAMPP .app packages, as have yet to find any other installer/uninstaller that gives me the same hardships.
If anyone has any information to the contrary I greatly appreciate it.

Thanks
xipasduarte
 
Posts: 3
Joined: 20. November 2014 02:41
Operating System: OS 10.7 Lion

Re: Installer does not start

Postby xipasduarte » 20. November 2014 19:02

It turns out my issue was completely unrelated to the XAMPP.app. I am sorry for any inconvenience.
Doe to some action I preformed (of which I am not totally aware yet), the PATH available to applications was rewritten to something that did not include default system folders such as
Code: Select all
/usr/bin

For this reason the XAMPP installer, and any other .app associated with XAMPP, could not start because they did not have access to dependencies installed on such folders as the above mentioned.

I amended the PATH for applications at
Code: Select all
~/.MacOSX/environment.plist
xipasduarte
 
Posts: 3
Joined: 20. November 2014 02:41
Operating System: OS 10.7 Lion


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests