XAMPP - Mysql stopped working on OS X Yosemite (10.10)

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMPP - Mysql stopped working on OS X Yosemite (10.10)

Postby vivekrajns » 18. October 2014 10:15

I was working with XAMPP 1.8.3-3 on OS X Mavericks. After upgrading to Yosemite Mysql server stopped working. And an upgrade to XAMPP 1.8.3-5 fixed the problem and mysql server starts working.

Now the entire database list is showing on phpmyadmin, but no access to the tables. Its showing “#1146 - Table ‘DB_NAME.TABLE_NAME’ doesn’t exist”.

Unfortunately I don't have any DB backup!

I have the entire XAMPP folder backup. So how I can able to retrieve the mysql tables?
vivekrajns
 
Posts: 4
Joined: 18. October 2014 10:13
Operating System: OS X 10.10

Re: XAMPP - Mysql stopped working on OS X Yosemite (10.10)

Postby skier » 18. October 2014 21:59

Hi, I have the same problem. I updated to 1.8.3-5 and everytime I try the URL of a project i.e localhost/myproject I get this error:

Error displaying the error page: Application Instantiation Error: Could not connect to MySQL.

In phpmyadmin I see all my databases but if I go into users section, users i had created for each database are not longer there. I tried to create again a user and gave it all the privileges for one of the databases but still not working now i get this error:

Error displaying the error page: Application Instantiation Error: Table 'eeearropaje.eee_session' doesn't exist SQL=SELECT `session_id` FROM `eee_session` WHERE `session_id` = 's4h10so2t8uv44m45uabvrkgv7' LIMIT 0, 1

I don't have backup either. How I can solve this problem and link the databases with users again? Its really important and urgent, i was working on a project i need to finish for this week and i cant even access it

Thanks
skier
 
Posts: 1
Joined: 18. October 2014 21:52
Operating System: macosx yosemite


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests