Setting up and problem with 403 error

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Setting up and problem with 403 error

Postby mirekstrnad1 » 07. July 2014 09:19

I am running on latest OS X Mavericks and latest XAMPP. I am having problems with making the xampp run.

My vhosts record look like this:

Code: Select all
<VirtualHost *:80>
    ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot "/Users/miroslavstrnad/Dropbox/Dokumenty/My Web Sites/vývoj/mirekstrnad.eu"
    ServerName mirekstrnad.dev
    ServerAlias *.mirekstrnad.dev
    ErrorLog "logs/dummy-host.example.com-error_log"
    CustomLog "logs/dummy-host.example.com-access_log" common
<Directory "/Users/miroslavstrnad/Dropbox/Dokumenty/My Web Sites/vývoj/mirekstrnad.eu">
     Options Indexes FollowSymLinks Includes ExecCGI
   AllowOverride All
   Order allow,deny
   Allow from all
   Require all granted
  </Directory>
</VirtualHost>


I also have the record in etc/hosts, but I am getting the Error 403 all the time.

What is wrong?
mirekstrnad1
 
Posts: 3
Joined: 07. July 2014 09:15
Operating System: OS X 10.9

Re: Setting up and problem with 403 error

Postby Nobbie » 07. July 2014 13:28

/Users/miroslavstrnad/Dropbox/Dokumenty/My Web Sites/vývoj/mirekstrnad.eu

is not accessible for the User which executes Apache.
Nobbie
 
Posts: 8783
Joined: 09. March 2008 13:04

Re: Setting up and problem with 403 error

Postby mirekstrnad1 » 07. July 2014 13:57

how to make it?
mirekstrnad1
 
Posts: 3
Joined: 07. July 2014 09:15
Operating System: OS X 10.9

Re: Setting up and problem with 403 error

Postby Nobbie » 07. July 2014 17:20

Read your OSX Manual and/or ask Apple or in an OSX forum, this question is not related to Xampp.
Nobbie
 
Posts: 8783
Joined: 09. March 2008 13:04

Re: Setting up and problem with 403 error

Postby mirekstrnad1 » 08. July 2014 08:29

Oh come on, where is the spirit of the community? I expected more friendly environment :(
mirekstrnad1
 
Posts: 3
Joined: 07. July 2014 09:15
Operating System: OS X 10.9

Re: Setting up and problem with 403 error

Postby Nobbie » 08. July 2014 11:37

Sorry, this is not an OSX community. I dont know how to change file permissions in your "explorer" (i even dont know, if you are using kind of "explorer" or whatelse).

I can tell you, that file permissions can also be set via chmod command in a terminal, but this requires basic knowledge how file permissions are working under OSX (i.e. any unix like system).

You may try

sudo chmod 0777 /foldername

in a terminal, but do you really have the slightest idea, what this command does? I really would like you to read some documentation and learn, how your operating system is working. It is never a good idea simply to provide a cryptic looking solution, as it does not help you in similar cases (and possibly it does not solve your problem immediately, maybe chmod must be run with some further options).
Nobbie
 
Posts: 8783
Joined: 09. March 2008 13:04

Re: Setting up and problem with 403 error

Postby petruza » 29. July 2014 15:20

Miroslav, it's possible that some folder in the path /Users/miroslavstrnad/Dropbox/Dokumenty/My Web Sites/vývoj/mirekstrnad.eu, most likely Dropbox is set so only you have read permission, that's the idea in a user's home folder, I had the same issue with Desktop.

Try this:
Locate the httpd.conf, it should be at /Applications/XAMPP/xamppfiles/etc/
Locate the following lines and change denied for granted so it looks like this:
Code: Select all
<Directory />
    AllowOverride none
    Require all granted
</Directory>


If that doesn't help, try also to set up a virtual host outside the /Users folder, for example in /test

Hope this helps.
petruza
 
Posts: 8
Joined: 27. September 2009 19:29

Re: Setting up and problem with 403 error

Postby Altrea » 29. July 2014 18:15

petruza wrote:Try this:
Locate the httpd.conf, it should be at /Applications/XAMPP/xamppfiles/etc/
Locate the following lines and change denied for granted so it looks like this:
Code: Select all
<Directory />
    AllowOverride none
    Require all granted
</Directory>

Really really really (!!!) bad idea to overwrite the default behavior to allow everything.
This is a huge security issue !!!
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 7 guests