Accessing Apache Web Server

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Accessing Apache Web Server

Postby MidgetDogg » 01. April 2014 13:37

I've downloaded XAMPP and am trying to connect to the Apache Web Server through the Manager. I can connect to the MySQL Database and ProFTPD , but Apache Web will not connect. When I type in HTTP://LOCALHOST, I just get a page that says, It Works! I haven't done anything with any of the set-up, just let the install do what it does.

Here is the Application Log

Starting Apache Web Server...
/Applications/XAMPP/xamppfiles/apache2/scripts/ctl.sh : httpd started
Starting Apache Web Server...
/Applications/XAMPP/xamppfiles/apache2/scripts/ctl.sh : httpd started
Starting all servers...
Starting MySQL Database...
/Applications/XAMPP/xamppfiles/mysql/scripts/ctl.sh : mysql started at port 3306
Starting Apache Web Server...
/Applications/XAMPP/xamppfiles/apache2/scripts/ctl.sh : httpd started
Starting ProFTPD...
Checking syntax of configuration file
/Applications/XAMPP/xamppfiles/proftpd/scripts/ctl.sh : proftpd started
Exit code:
Stdout:

Stderr:

Stopping MySQL Database...
Stopping ProFTPD...
Checking syntax of configuration file
/Applications/XAMPP/xamppfiles/proftpd/scripts/ctl.sh : proftpd stopped
/Applications/XAMPP/xamppfiles/mysql/scripts/ctl.sh : mysql stopped
Starting Apache Web Server...
/Applications/XAMPP/xamppfiles/apache2/scripts/ctl.sh : httpd started
Starting Apache Web Server...

Starting Apache Web Server...

Starting all servers...
Starting MySQL Database...

Starting Apache Web Server...

Starting ProFTPD...
Checking syntax of configuration file
/Applications/XAMPP/xamppfiles/proftpd/scripts/ctl.sh : proftpd started
Stopping all servers...
Stopping MySQL Database...
/Applications/XAMPP/xamppfiles/mysql/scripts/ctl.sh : mysql stopped
Stopping ProFTPD...
Checking syntax of configuration file
/Applications/XAMPP/xamppfiles/proftpd/scripts/ctl.sh : proftpd stopped
Starting Apache Web Server...
/Applications/XAMPP/xamppfiles/apache2/scripts/ctl.sh : httpd started
MidgetDogg
 
Posts: 3
Joined: 01. April 2014 13:21
Operating System: Mac OS

Re: Accessing Apache Web Server

Postby MidgetDogg » 01. April 2014 13:44

There's this too.

You have new mail.
/Applications/XAMPP/xamppfiles/xampp ; exit;
macintosh-3:~ (removed for security)$ /Applications/XAMPP/xamppfiles/xampp ; exit;
Usage: xampp <action>

start Start XAMPP (Apache, MySQL and eventually others)
startapache Start only Apache
startmysql Start only MySQL
startftp Start only ProFTPD

stop Stop XAMPP (Apache, MySQL and eventually others)
stopapache Stop only Apache
stopmysql Stop only MySQL
stopftp Stop only ProFTPD

reload Reload XAMPP (Apache, MySQL and eventually others)
reloadapache Reload only Apache
reloadmysql Reload only MySQL
reloadftp Reload only ProFTPD

restart Stop and start XAMPP
security Check XAMPP's security

enablessl Enable SSL support for Apache
disablessl Disable SSL support for Apache

backup Make backup file of your XAMPP config, log and data files

oci8 Enable the oci8 extenssion

fix_rights Resets file permissions.

logout

[Process completed]
MidgetDogg
 
Posts: 3
Joined: 01. April 2014 13:21
Operating System: Mac OS

Re: Accessing Apache Web Server

Postby MidgetDogg » 02. April 2014 00:58

I got the answer for this and all is well now.

This usually means that you have the Apple version of the Apache Web Server already running.
Apple provides a version of the Apache Web Server with OS X. I chose to use XAMPP because it includes PHP and the MySQL server all in one package.

You cannot install XAMPP with Apache already running on your Mac. If you see "It works!" when you open your browser and type "localhost" into the address bar, this means that the Apple version of Apache is already running. You cannot run two instances of a web server at once, so the Apple Apache must be stopped before you can install XAMPP.

In OSX 10.7 and earlier, you could start and stop the Apache Web Server in Control Panel, by choosing "Sharing" and then unchecking the "Web Sharing" checkbox. As of 10.8 this option is no longer in the control panel.

To disable Apple's version of Apache in current versions of OS X, open a Terminal window and type this command:

sudo apachectl stop

You will need to type your system password when prompted, then you should be able to start the XAMPP version of Apache.
MidgetDogg
 
Posts: 3
Joined: 01. April 2014 13:21
Operating System: Mac OS

Re: Accessing Apache Web Server

Postby Drummer » 24. May 2014 12:10

Excellent! This worked for me! :D
Drummer
 
Posts: 1
Joined: 24. May 2014 12:03
Operating System: osx

Re: Accessing Apache Web Server

Postby cls550 » 28. May 2014 17:02

This works for me! Thank you so much for the great info!
cls550
 
Posts: 1
Joined: 28. May 2014 17:00
Operating System: mac osX 10.9

Re: Accessing Apache Web Server

Postby agrawalc » 09. August 2014 21:26

Works for me, thank you so much man!
agrawalc
 
Posts: 1
Joined: 09. August 2014 21:24
Operating System: MAC OS X 10.9.3


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests