Disable FTP auto-start

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Disable FTP auto-start

Postby spookybathtub » 11. March 2014 06:20

For some time I've been running XAMPP 1.8.2 on Mavericks, and I had a LaunchDaemon run this command at startup:
Code: Select all
/Applications/XAMPP/xamppfiles/xampp start

It started Apache and MySQL only.

Now I have a new system running XAMPP 1.7.3 on Mountain Lion, and I want to do the same thing, but that command tries to start FTP also. Why is this behavior different, and how can I change it? And yes, of course I know I could issue two commands: "startapache" and "startmysql", but I never had to do that before.

Also, I'm getting this error now:
Code: Select all
$ sudo /Applications/XAMPP/xamppfiles/xampp start
Starting XAMPP for Mac OS X 1.7.3...
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD.../Applications/XAMPP/xamppfiles/xampp: line 184: /Applications/XAMPP/xamppfiles//var/proftpd/start.err: No such file or directory
fail.
Contents of "/Applications/XAMPP/xamppfiles//var/proftpd/start.err":
cat: /Applications/XAMPP/xamppfiles//var/proftpd/start.err: No such file or directory
spookybathtub
 
Posts: 10
Joined: 02. June 2013 04:19
Operating System: 10.8.3

Re: Disable FTP auto-start

Postby spookybathtub » 17. March 2014 08:13

I found the answer by reading through the startup script. Just delete the file /Applications/XAMPP/xamppfiles/xetc/xampp/startftp, then the "start" command won't try to start it.
spookybathtub
 
Posts: 10
Joined: 02. June 2013 04:19
Operating System: 10.8.3


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests

cron