Java call no longer returning value

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Java call no longer returning value

Postby chontler » 17. January 2014 19:26

I upgraded to a new mac. After reinstalling everything and running my local development server it seems the web server can no longer
I am executing a java file:

$str_exec = "java -jar jar/java.jar args";
exec($str_exec, $output);

only ever returns array()

The java writes a json file to a local directory and also spits out the result.

This has always worked before and the code mimics our webserver, so I realize this might not be specific to xampp, but this is the only server I've used.
I've tried all manner of absolute and relative paths, and changed permissions on files and directories all day.

The only error that I get is:

dyld: Symbol not found: __cg_jpeg_resync_to_restart
Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
Expected in: /Applications/XAMPP/xamppfiles/lib/libJPEG.dylib
in /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO

If anyone can shed some light on this I'd be ever so grateful.

XAMPP 1.8.3-2 Mavericks
Posts: 1
Joined: 17. January 2014 19:17
Operating System: mavericks

Return to XAMPP for macOS

Who is online

Users browsing this forum: No registered users and 9 guests