XAMPP Apache conflicting with OS X Apache

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

XAMPP Apache conflicting with OS X Apache

Postby mmb » 15. November 2013 21:17

I wanted to install XAMPP to do some local testing but leave my OS X system Apache running.
XAMPP allows to change the port of Apache but the setting is ignored by the startup script that fails.
I'd like to share the problem and the solution I used.

Apache fails to start, Apache's "led" remains red
The application log gives no message
Running by hand
Code: Select all
/Applications/XAMPP/xamppfiles/xampp startapache
you get the error message:
'Another web server is already running.'

The problem is that the script is always looking for port 80, even if I configured XAMPP's apache to use 8280.
A workaround is to stop the system Apache, start XAMPP's Apache, start the system Apache.

XAMPP code should be changed in XAMPP/xamppfiles/xampp startapache, function startApache from:
Code: Select all
        if testport 80

to
Code: Select all
        xampp_http_port=`egrep "^Listen" xamppfiles/etc/httpd.conf | sed 's;[^:]*:;;'`
        if testport $xampp_http_port

I don't know if this is the best way to suggest a code change.
Please advise. Thanks

I'm using XAMPP 1.8.3-1 on OS X 10.6.8
mmb
 
Posts: 1
Joined: 15. November 2013 20:40
XAMPP Version: 1.8.3-3
Operating System: os x

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 6 guests