phpmyadmin not working after installing 1.8.2

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

phpmyadmin not working after installing 1.8.2

Postby DJAY » 16. July 2013 20:10

After deleting my old version of XAMPP and installing version 1.8.2, I could not log into phpmyadmin. And once I did, I was unable to do anything as it gave me a mismatch error whenever I clicked on a button. After getting rid of that, I could not import my old database backup.

Also, as a side note - the xampp security program did not seem to set the password for the root user.
For those of you who can't figure out how to run the xampp security program - as it is kind of hidden, open up your "Terminal" and type the following:

Assuming that you have XAMPP installed under Applications and the name of the folder is XAMPP:

Code: Select all
cd /Applications/XAMPP/xamppfiles
sudo ./xampp security


And then follow the instructions for the program.

Here was my solution for the other problems:

In the php.ini file (found under XAMPP/xamppfiles/etc), I uncommented the line found under

;where MODE is the octal representation of the mode. Note that this
; does not overwrite the process's umask.
; http://php.net/session.save-path


The line uncommented and edited was this:

Code: Select all
session.save_path = "/tmp"


I added this part:
"/tmp"


Then in the config.inc.php file (found under XAMPP/xamppfiles/phpmyadmin), I set the password for root by changing this line to be equal to my desired password:

$cfg['Servers'][$i]['password'] = ''


Then, I changed the blowfish_secret:

$cfg['blowfish_secret'] = 'xampp'


You can change the blowfish secret to whatever you want - it makes it more secure.

Alright, now you should be able to login and use phpmyadmin if you were having any issues with the cookie mismatch problem.


Now for the importing problem:

Going back to the php.ini file, I changed the following to accommodate the size of my database file to import:

post_max_size
upload_max_filesize
memory_limit
(I did not change this one but you might have to: max_input_time)

Then, I changed the upload_tmp_dir to equal /tmp (this step is important) like so:

Code: Select all
upload_tmp_dir = /tmp


Notice that there are no quotes.

And walla! My database import was successful (after one more step).

I had accidentally included some databases in the backup that I had not meant to including information_schema, performance_schema, and mysql. This resulted in the import not completing once it ran into conflict with these tables. So I opened up the sql file in a simple text editor (be careful of opening it in a fancy editor - as the file is quite large and the editor might blow up) and removed the unwanted databases.

Hope this helps someone out there!
DJAY
 
Posts: 4
Joined: 16. July 2013 19:36
XAMPP Version: 5.5.19
Operating System: Mac OS X Mountain Lion

Re: phpmyadmin not working after installing 1.8.2

Postby Beltran » 17. July 2013 18:58

Thanks for posting it. We are working on fix this issue.
User avatar
Beltran
Power-User
 
Posts: 77
Joined: 22. March 2013 12:29
XAMPP Version: 5.5.19
Operating System: Windows, Linux, OS X

Re: phpmyadmin not working after installing 1.8.2

Postby Beltran » 18. July 2013 09:52

We have just published a new version that fixes this issue: 1.8.2-1

http://www.apachefriends.org/en/xampp-macosx.html

I hope it helps.
User avatar
Beltran
Power-User
 
Posts: 77
Joined: 22. March 2013 12:29
XAMPP Version: 5.5.19
Operating System: Windows, Linux, OS X

Re: phpmyadmin not working after installing 1.8.2

Postby DJAY » 12. September 2013 06:20

Beltran wrote:We have just published a new version that fixes this issue: 1.8.2-1

http://www.apachefriends.org/en/xampp-macosx.html

I hope it helps.


Awesome! Nice work. Thanks for posting - I'm actually reinstalling it again on another computer - so this makes it easier

Beltran wrote:Thanks for posting it. We are working on fix this issue.


No problem at all!
DJAY
 
Posts: 4
Joined: 16. July 2013 19:36
XAMPP Version: 5.5.19
Operating System: Mac OS X Mountain Lion


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests