Update PHP from 5.3.1 to 5.3.10

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Update PHP from 5.3.1 to 5.3.10

Postby mrdmadev » 09. February 2012 06:38

Hello!

I've been using XAMPP for windows xp and I recently started using it on MAC OSX. I was hoping someone can either outline the steps involved or point me to a resource to update the php version. I have 5.3.8 on my windows XAMPP install and I'm getting weird warnings/errors from php using 5.3.1 that I can't seem to figure out. The only difference between the two installs (as far as I can tell) is the PHP versions.

Thank you in advance!
mrdmadev
 
Posts: 3
Joined: 09. February 2012 06:27
XAMPP Version: 1.8.3-2
Operating System: MAC OSX 10.6.8

Re: Update PHP from 5.3.1 to 5.3.10

Postby giuliano-losi » 11. February 2012 10:25

Mac OS X project is paused.

Giuliano
giuliano-losi
 
Posts: 3
Joined: 04. February 2012 10:14
XAMPP Version: 1.8.3-2
Operating System: Mac OS X

Re: Update PHP from 5.3.1 to 5.3.10

Postby mrdmadev » 11. February 2012 18:08

I know this. However, I was sure someone could help me with the updating of PHP, not XAMPP. Two different things. Thanks anyway.

It looks like I'll have to ask on a PHP forum.
mrdmadev
 
Posts: 3
Joined: 09. February 2012 06:27
XAMPP Version: 1.8.3-2
Operating System: MAC OSX 10.6.8

Re: Update PHP from 5.3.1 to 5.3.10

Postby Altrea » 11. February 2012 20:11

Hi mrdmadev,

mrdmadev wrote:I'm getting weird warnings/errors from php using 5.3.1 that I can't seem to figure out. The only difference between the two installs (as far as I can tell) is the PHP versions.


Which warnings/errors?
In 99% of all cases an update where just the revision (third number of the version number) changes will not solve such issues.

and please remember one thing: XAMPP is a preconfigured stack of webserver components and only supported as a stack. Updating any of the single components is not supported and in some cases very difficult (if not impossible).

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6482
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Update PHP from 5.3.1 to 5.3.10

Postby mrdmadev » 11. February 2012 20:22

Altrea -

Thanks for the input on updating PHP. I figured out the source of my errors. I'm developing a backend for my mobile apps and I am sending JSON encoded variables back to my app. I'm also using codeigniter which uses a library to destroy a session. The error I was getting was from destroying the session after sending the JSON response. My XAMPP server on my windows machine which has the newer version of PHP must be more forgiving. I traded the two places (the sequence) of destroying the session before sending my JSON and all works well on both servers.
mrdmadev
 
Posts: 3
Joined: 09. February 2012 06:27
XAMPP Version: 1.8.3-2
Operating System: MAC OSX 10.6.8


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests