wildcard dns, mod_rewrite, outside xampp/htdocs

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

wildcard dns, mod_rewrite, outside xampp/htdocs

Postby barat » 06. February 2012 22:25

Hello ...
I have a little (well ... large) problem.

I've set up Wildcard DNS for my mac, and moved my htdocs direcory to /Volumes/data/www.
Everything seemed to be OK untill I checked .htaccess
No rewriting :/
I've uncommented LoadModule rewrite_module modules/mod_rewrite.so, phpinfo shows:
(...) mod_userdir mod_alias mod_rewrite mod_ssl mod_php5 mod_perl (...)


In my httpd-vhosts.conf I have:
Code: Select all
<VirtualHost *:80>
    ServerName dev
    ServerAlias *.dev
    ServerAdmin webmaster@localhost
    ErrorLog "logs/%1-error_log"
    CustomLog "logs/%1-access_log" common
    VirtualDocumentRoot "/Volumes/data/www/%-2"
    <Directory /Volumes/data/www/%-2>
        Options Indexes FollowSymLinks MultiViews Includes ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
</Virtualhost>

Main domains are working OK, wordpress is working OK untill I set permalinks for something else then Default...
I get only 404 for every subpage ...

What am I doing wrong? What else I should do to have rewriting ready to go?
barat
 
Posts: 3
Joined: 16. January 2012 16:51
XAMPP Version: 1.8.3-2
Operating System: OSX Snow Leopard

Re: wildcard dns, mod_rewrite, outside xampp/htdocs

Postby jingling » 07. February 2012 04:51

Yes, this is broken for me too on Windows environment. I think it is a bug in apache Windows and new versions of Wordpress
jingling
 
Posts: 2
Joined: 07. February 2012 04:48
XAMPP Version: 5.6.3
Operating System: 2003

Re: wildcard dns, mod_rewrite, outside xampp/htdocs

Postby barat » 09. February 2012 16:50

It's not wordpress...
I made just two files

index.php
Code: Select all
<?php
print_r($_GET);


And .htaccess
Code: Select all
Options FollowSymLinks
RewriteEngine On
RewriteRule ^test.html$ index.php?get=1 [L]


No results hen navgating to test.html - just 404

IMO .htaccess isn't even working - i can do something lie this:
Code: Select all
Options FollowSymLinks
RewriteEngine On
RewriteRule ^test.html$ index.php?get=1 [L]
THIS SHOULD BE error500 IF LEFT HERE


And on windows, Debian VPS other hosts - eror 500, and XAMPP Mac server is doing fine - no result, no error 500 ..
barat
 
Posts: 3
Joined: 16. January 2012 16:51
XAMPP Version: 1.8.3-2
Operating System: OSX Snow Leopard


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests