Options -Indexes causes Error

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Options -Indexes causes Error

Postby krb19xx » 06. January 2012 03:54

In httpd.conf I've got DocumentRoot "/Users/xxxxxxxxxxx/Sites" and <Directory "/Users/xxxxxxxxxxx/Sites"> with AllowOverride All in it.

I'm also using a VirtualHost pointing to a directory at /Users/xxxxxxxxxxx/Sites/yyyy

Everything seems to be working OK except that when I put Options -Indexes in my .htaccess file in my yyyy directory I get an Apache server configuration error.

The other Directives in .htaccess seem to be working fine, but I can't get #@%&%@& Options -Indexes to work!

If anyone could help I would greatly appreciate it!
krb19xx
 
Posts: 1
Joined: 01. January 2012 18:27
XAMPP Version: 1.8.3-2
Operating System: Mac OS X v10.6.8

Re: Options -Indexes causes Error

Postby Sharley » 06. January 2012 04:23

Could you try
Code: Select all
Options All -indexes
Please let me know if it helps.

Also you should have an error.log file in the Apache tree, perhaps apache\logs see if it has a clue about this issue.

An alternate solution to the Options directive would be to use
Code: Select all
IndexIgnore *


This link has a host of the well known .htaccess tricks:
prevent unauthorized directory browsing

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 5 guests