CGI can't find Perl Modules

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

CGI can't find Perl Modules

Postby choip » 06. November 2011 23:32

Hi I'm new on this forum, so I apologize ahead if this has been addressed somewhere but I can't seem to find it.

Basically, does anyone know why even after I sudo install on cpan this LWP module, the output gives me a 500 Server error

cpan shell -- CPAN exploration and modules installation (v1.9456)
Enter 'h' for help.

cpan[1]> install LWP::Simple
Going to read '/var/root/.cpan/Metadata'
Database was generated on Sat, 05 Nov 2011 19:27:17 GMT
LWP::Simple is up to date (6.00).

OutputError message:

Server error!

The server encountered an internal error and was unable to complete your request.

Can't locate LWP/ in @INC (@INC contains: /Applications/XAMPP/xamppfiles/lib/perl5/site_perl/5.10.1//darwin-2level /Applications/XAMPP/xamppfiles/lib/perl5/site_perl/5.10.1/ /Applications/XAMPP/xamppfiles/lib/perl5/5.10.1/darwin-2level

I tried to integrate all the info in this post:

But, it seems like the module library is not hooked up through XAMPP. Could it be that there is a disconnect between the cpan modules for what perl looks from the system vs xampp's bin/perl? I'm no expert so I just dunno.

Thanks for any help!
Posts: 1
Joined: 06. November 2011 23:22
XAMPP Version: 1.8.2-4
Operating System: Mac OS X 10.6

Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests