What about XAMPP in MacOS?

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

What about XAMPP in MacOS?

Postby lgruz » 21. October 2011 10:19

Hi,
I've always used XAMPP as Server for MacOS, but currently is the only operating system that maintains an old version of PHP and MySQL. When will we leave for version 1.7.3? I'm using Zend Server as alternative, with PHP 5.3.8.

Thanks
lgruz
 
Posts: 6
Joined: 19. September 2011 13:03
XAMPP Version: 1.8.3-2
Operating System: MacOS 10.7.2

Re: What about XAMPP in MacOS?

Postby Altrea » 21. October 2011 17:08

Why don't you want to stay with Zend Server? I don't think, thats such a bad choice :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: What about XAMPP in MacOS?

Postby lgruz » 21. October 2011 17:57

Altrea wrote:Why don't you want to stay with Zend Server? I don't think, thats such a bad choice :D


Like you, I'm using XAMPP for development, and I want to use Zend Server CE in the future for the final Server. But I can't develop an application with PHP 5.3.1, and use with PHP 5.3.8, because it's functions/options/errors that isn't in 5.3.1, or in XAMPP 1.7.7 in Windows. More errors (or Advices) and some functions doesn't work correctly.

That's is the problem. Only Mac users are being "discriminated", and I don't understand it.
lgruz
 
Posts: 6
Joined: 19. September 2011 13:03
XAMPP Version: 1.8.3-2
Operating System: MacOS 10.7.2

Re: What about XAMPP in MacOS?

Postby Altrea » 21. October 2011 18:41

lgruz wrote:Like you, I'm using XAMPP for development, and I want to use Zend Server CE in the future for the final Server.

I have development machines with Zend Server(CE) and XAMPP. If i use a Zend Server or Zend Server (CE) anywhere as live system, i try to use Zend Server (CE) with the same configuration (if possible) as development machine.
I have some older server configurations where i use XAMPP 1.4.13 or XAMPP 1.6.8 (the last XAMPP with PHP4/5 switch) for development.

lgruz wrote:But I can't develop an application with PHP 5.3.1, and use with PHP 5.3.8, because it's functions/options/errors that isn't in 5.3.1, or in XAMPP 1.7.7 in Windows

for example?

lgruz wrote:More errors (or Advices) and some functions doesn't work correctly.

for example?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: What about XAMPP in MacOS?

Postby lgruz » 24. October 2011 07:41

Altrea wrote:for example?


Here you have a complete ChangeLog of version from 5.3.1 to 5.3.8, with changes like return false in some functions, deprecated functions, another advices...

http://www.php.net/ChangeLog-5.php#5.3.1
lgruz
 
Posts: 6
Joined: 19. September 2011 13:03
XAMPP Version: 1.8.3-2
Operating System: MacOS 10.7.2

Re: What about XAMPP in MacOS?

Postby Sharley » 24. October 2011 08:12

Igruz wrote:When will we leave for version 1.7.3?
If your game there is a beta 1.7.5 available from here...
http://sourceforge.net/projects/xampp/f ... g/download
...but you would have to download it to see what version the components are:


If you have any issues with a beta version then use the form on this page...
http://www.apachefriends.org/en/xampp-beta.html
...to contact the developer not in these forums as it is not a final release and so is not yet supported.:
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: What about XAMPP in MacOS?

Postby Altrea » 25. October 2011 05:27

lgruz wrote:Here you have a complete ChangeLog of version from 5.3.1 to 5.3.8, with changes like return false in some functions, deprecated functions, another advices...

http://www.php.net/ChangeLog-5.php#5.3.1

Thank you very much, but i already know the changelog.

What i wanted to say is that in most of the cases you don't see any difference between PHP 5.3.1 and PHP 5.3.8 exept you accidentally hit one of the Bugs which are solved in later patches.
Most of the common php script run very well on both of the version (i just can name you one which don't: mediawiki don't run on PHP 5.3.1 because of a bug in a php function).

Remember one thing, the third part of a version number is not a major release, not a minor release, it is just a patch level number.

P.S.: deprecated functions only change in minor releases (+), not patch levels.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests