OSX 10.7.2 MySQL running - port 3306 closed

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

OSX 10.7.2 MySQL running - port 3306 closed

Postby sgordon46 » 13. October 2011 21:01

Welcome to

MySQL starts on port 3306, I am able to access the database via phpmyadmin without a problem.

I have a web app in PHP running in apache XAMPP able to connect and process SQL

I am also able to command line into the server : ./mysql -u root -p


sgordon:xamppfiles sgordon$ nmap -P0 localhost -p 3306

Starting Nmap 5.21 ( http://nmap.org ) at 2011-10-13 14:38 CDT
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00013s latency).
PORT STATE SERVICE
3306/tcp closed mysql


I am unable to telnet to the service.

I am unable to configure my coldfusion database -> Data Sources to this MySql Database. This is the primary issue. Suggestions??

I have tried both with firewall on and off. I have tried restarting.

Seems to have something to do with where the PHP files are located, but that does not make sense. Below are the process with mysql running.

sgordon:xamppfiles sgordon$ ps -aef | grep mysql
0 1562 1 0 2:38PM ttys000 0:00.02 /bin/sh /Applications/XAMPP/xamppfiles/bin/mysqld_safe --datadir=/Applications/XAMPP/xamppfiles/var/mysql --pid-file=/Applications/XAMPP/xamppfiles/var/mysql/sgordon.local.pid
-2 1667 1562 0 2:38PM ttys000 0:00.49 /Applications/XAMPP/xamppfiles/sbin/mysqld --basedir=/Applications/XAMPP/xamppfiles --datadir=/Applications/XAMPP/xamppfiles/var/mysql --user=nobody --log-error=/Applications/XAMPP/xamppfiles/var/mysql/sgordon.local.err --pid-file=/Applications/XAMPP/xamppfiles/var/mysql/sgordon.local.pid --socket=/Applications/XAMPP/xamppfiles/var/mysql/mysql.sock --port=3306
sgordon46
 
Posts: 1
Joined: 13. October 2011 20:47

Re: OSX 10.7.2 MySQL running - port 3306 closed

Postby JonB » 17. October 2011 03:44

I think it might be related to the issue in this topic

viewtopic.php?f=29&t=48613

I suspect this 'used to work' right???

Did you just update the Mac OS??? If so, I'm guessing a permissions or ownership issue.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 2 guests